diff mbox series

[bug#49199,core-updates] add package-db to runhaskell (haskell-build-system)

Message ID GMVhpmT-cIIS8fxdoEunZXx-wTfXa1TvInI4206RxKZrrdyYkv4bhgg7qt502kNulYAbvZdRcnpA7ft-zq88cOzBga-leAkk_Bzc8msPZ54=@protonmail.com
State Accepted
Headers show
Series [bug#49199,core-updates] add package-db to runhaskell (haskell-build-system) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias June 23, 2021, 10:09 p.m. UTC
Hello,

This is a patch to fix issue #48944 as well as more broadly an issue of Haskell packages that need modules at the configure step. Currently the package database is not passed to runhaskell directly, which means runhaskell Setup.hs configure does not have outside modules available. This blocks packages that need things like cabal-doctest or gtk2hs-buildtools like ghc-cairo (which has a custom build process in the package currently, for this reason). Comments in ghc-cairo and for other packages with this need, suggest the change made in this patch.

The simplest change I saw was to make the package database passed to runhaskell on any command; not sure if this would be better for just configure. It may be possible to do this just passing the actual needed packages with -package-id, as suggested in https://github.com/tweag/rules_haskell/issues/1314 However, I have not tried that and seemed more complicated than needed. Also, I did not modify the message printed as it already has the package-db in params, but perhaps better to be clear the exact command being run?

I have built many Haskell packages with this change and it works well for me, fixing the reported issue and packages I'm building not yet in guix. Given this changes the build command for all Haskell packages, would be happy for other tests to be run.

John

Comments

Philip Munksgaard July 2, 2021, 7:38 a.m. UTC | #1
This works for me. How can we get it merged?
John Kehayias July 4, 2021, 12:47 a.m. UTC | #2
I don't know, I'm rather new here :-) We'll need one of the main devs I guess to do it? The patch I submitted was actually from the master branch, but haskell-build-system is identical in core-updates if I'm reading the git log correctly. But I'm happy to do more testing on the core-updates branch.
John Kehayias July 5, 2021, 4:17 p.m. UTC | #3
Looks like you (and me) have run into several of these problems that could be revised with some fixes to haskell-build-system and the hackage importer. On #guix it was discussed having a branch to try out these changes and leverage the CI to see what breaks on making changes to the build system, ghc version, etc.

We'll need someone to create and let us push there, not sure who to ask or how to get started on that...
Ricardo Wurmus July 20, 2021, 10:22 p.m. UTC | #4
Hi,

I made a commit out of the diff and pushed it to wip-haskell, 
which is based on core-updates.
diff mbox series

Patch

diff --git a/guix/build/haskell-build-system.scm b/guix/build/haskell-build-system.scm
index 28253ce2f0..be20f13e10 100644
--- a/guix/build/haskell-build-system.scm
+++ b/guix/build/haskell-build-system.scm
@@ -63,13 +63,14 @@ 
                      ((file-exists? "Setup.lhs")
                       "Setup.lhs")
                      (else
-                      #f))))
+                      #f)))
+        (pkgdb (string-append "-package-db=" %tmp-db-dir)))
     (if setup-file
         (begin
           (format #t "running \"runhaskell Setup.hs\" with command ~s \
 and parameters ~s~%"
                   command params)
-          (apply invoke "runhaskell" setup-file command params))
+          (apply invoke "runhaskell" pkgdb setup-file command params))
         (error "no Setup.hs nor Setup.lhs found"))))
 
 (define* (configure #:key outputs inputs tests? (configure-flags '())
-- 
2.32.0