diff mbox series

[bug#49526] Add cl-authentic

Message ID WSF1P2lfLXTm1ilfGm48bmpgzDcVj_olEzPhNY6jk3bRgNSYseyvhCNnLDM-i7REPQbZKtCuZdKVpBXpUDytFC4rN8PdO6E1VPR3tYaI-QU=@protonmail.com
State Accepted
Headers show
Series [bug#49526] Add cl-authentic | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Charles July 12, 2021, 1:25 p.m. UTC
Woops, yes. I forgot to pull to local before copying the comit and hash. I have attatchhed an updated patch.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Monday, July 12th, 2021 at 4:41 AM, Guillaume Le Vaillant <glv@posteo.net> wrote:

> When applying this patch, should I also update it to the most recent
>
> upstream commit (d5ff2f4666ce24e41fb4ca22476c782c070e6f6e)?

Comments

Guillaume Le Vaillant July 12, 2021, 3:07 p.m. UTC | #1
Charles <charles.b.jackson@protonmail.com> skribis:

> Woops, yes. I forgot to pull to local before copying the comit and hash. I have attatchhed an updated patch.
>
> ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
>
> On Monday, July 12th, 2021 at 4:41 AM, Guillaume Le Vaillant <glv@posteo.net> wrote:
>
>> When applying this patch, should I also update it to the most recent
>>
>> upstream commit (d5ff2f4666ce24e41fb4ca22476c782c070e6f6e)?

Patch pushed as 62b60ba08249cbe239f3abe033a15fac83c4b54a.
Thanks.
diff mbox series

Patch

From 3ab5d94047836d4c6887fabe070803626f635611 Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Wed, 7 Jul 2021 21:41:36 -0500
Subject: [PATCH] gnu: Add cl-authentic.

* gnu/packages/lisp-xyz.scm (sbcl-authentic, ecl-authentic, cl-authentic): Add new variables.
---
 gnu/packages/lisp-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fe1c010811..9aa5c854a7 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16485,6 +16485,37 @@  for Common Lisp.")
 (define-public cl-bknr-datastore
   (sbcl-package->cl-source-package sbcl-bknr-datastore))
 
+(define-public sbcl-authentic
+  (let ((commit "d5ff2f4666ce24e41fb4ca22476c782c070e6f6e")
+        (revision "1"))
+    (package
+      (name "authentic")
+      (version (git-version "0.1.0" revision commit))
+      (source
+       (origin
+         (method url-fetch)
+         (uri "/home/charles/cl-authentic")
+         (sha256
+          (base32 "1dmi9lw1ickx0i41lh9sfchalvy7km6wc9w3szfjlvny7svwf6qp"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("clsql" ,sbcl-clsql)
+         ("ironclad" ,sbcl-ironclad)))
+      (home-page "")
+      (synopsis "Provide a light-weight and extendible solution to
+user/password management for Common Lisp applicaitons")
+      (description "Authentic provides a light-weight and extendible
+solution to user/password management for Common Lisp applicaitons. It has
+features such as safe password storage in a database, password reset, user
+confirmation tokens, and user authentication.")
+      (license license:llgpl))))
+
+(define-public ecl-authentic
+  (sbcl-package->ecl-package sbcl-authentic))
+
+(define-public cl-authentic
+  (sbcl-package->cl-source-package sbcl-authentic))
+
 (define-public sbcl-3d-vectors
   (let ((commit "29bb9684df803590deed344af63dbf7b712aabc0")
         (revision "1"))
-- 
2.32.0