diff mbox series

[bug#49526] Add cl-authentic

Message ID VtwB1a4lXj29zs41RrQFG6FkGzZCHB0wgy0g4AIfLbYD05ExJZLGnn_KDWRBiGRfYPcdVDViB2u2hpa22nflIz49wybFO0hOXrpA5krmeFA=@protonmail.com
State Accepted
Headers show
Series [bug#49526] Add cl-authentic | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Charles July 11, 2021, 6:30 p.m. UTC
Empty Message

Comments

Guillaume Le Vaillant July 12, 2021, 9:41 a.m. UTC | #1
When applying this patch, should I also update it to the most recent
upstream commit (d5ff2f4666ce24e41fb4ca22476c782c070e6f6e)?
diff mbox series

Patch

From 5fd68ca75c3606311621b726960fdc3a680f992c Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Wed, 7 Jul 2021 21:41:36 -0500
Subject: [PATCH] gnu: Add cl-authentic.

* gnu/packages/lisp-xyz.scm (sbcl-authentic, ecl-authentic, cl-authentic): Add new variables.
---
 gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fe1c010811..a99f0fa301 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16485,6 +16485,40 @@  for Common Lisp.")
 (define-public cl-bknr-datastore
   (sbcl-package->cl-source-package sbcl-bknr-datastore))
 
+(define-public sbcl-authentic
+  (let ((commit "51aa6b2a13184eff773a5507ec12e08409789ba8")
+        (revision "1"))
+    (package
+      (name "sbcl-authentic")
+      (version (git-version "0.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/charje/cl-authentic")
+               (commit commit)))
+         (file-name (git-file-name "authentic" version))
+         (sha256
+          (base32 "1dmi9lw1ickx0i41lh9sfchalvy7km6wc9w3szfjlvny7svwf6qp"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("clsql" ,sbcl-clsql)
+         ("ironclad" ,sbcl-ironclad)))
+      (home-page "https://github.com/charje/cl-authentic")
+      (synopsis "Provide a light-weight and extendible solution to
+user/password management for Common Lisp applicaitons")
+      (description "Authentic provides a light-weight and extendible
+solution to user/password management for Common Lisp applicaitons. It has
+features such as safe password storage in a database, password reset, user
+confirmation tokens, and user authentication.")
+      (license license:llgpl))))
+
+(define-public ecl-authentic
+  (sbcl-package->ecl-package sbcl-authentic))
+
+(define-public cl-authentic
+  (sbcl-package->cl-source-package sbcl-authentic))
+
 (define-public sbcl-3d-vectors
   (let ((commit "29bb9684df803590deed344af63dbf7b712aabc0")
         (revision "1"))
@@ -18418,3 +18452,4 @@  bound to whatever value was in the same place in the URL (as a string).")
 
 (define-public cl-hunchenissr-routes
   (sbcl-package->cl-source-package sbcl-hunchenissr-routes))
+
-- 
2.32.0