diff mbox series

[bug#48729,v7,25/25] services: Add bitmask-service-type.

Message ID 20210701045728.7293-25-rg@raghavgururajan.name
State Accepted
Headers show
Series None | expand

Commit Message

Raghav Gururajan July 1, 2021, 4:57 a.m. UTC
* gnu/services/vpn.scm (bitmask-service-type): New variable.

Co-authored-by: jgart <jgart@dismail.de>
---
 gnu/services/vpn.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Tobias Geerinckx-Rice July 3, 2021, 3:02 a.m. UTC | #1
Raghav Gururajan via Guix-patches via 写道:
> +(define-public bitmask-service-type
> +  (service-type
> +   (name 'bitmask)
> +   (description "Setup the @uref{https://bitmask.net, Bitmask} 
> VPN application.")

…so this is an odd service, in that the polkit thing is apparently 
only a temporary hack, and the only other action is a trend I 
quite dislike: services assuming they may install random packages.

I understand if it's a necessary evil for now to keep things in 
sync.  Is that why it's undocumented?  :-)

Kind regards,

T G-R
Raghav Gururajan July 3, 2021, 6:53 a.m. UTC | #2
Hi Tobias!

> …so this is an odd service, in that the polkit thing is apparently only 
> a temporary hack, and the only other action is a trend I quite dislike: 
> services assuming they may install random packages.
> 
> I understand if it's a necessary evil for now to keep things in sync.

Yeah, it is only needed until polkit dependency is dropped by upstream.

> Is that why it's undocumented?  :-)

Added it in v9.

Regards,
RG.
diff mbox series

Patch

diff --git a/gnu/services/vpn.scm b/gnu/services/vpn.scm
index a51dda3873..55b4bd0b16 100644
--- a/gnu/services/vpn.scm
+++ b/gnu/services/vpn.scm
@@ -6,6 +6,8 @@ 
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
 ;;; Copyright © 2021 Domagoj Stolfa <ds815@gmx.com>
 ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +27,7 @@ 
 (define-module (gnu services vpn)
   #:use-module (gnu services)
   #:use-module (gnu services configuration)
+  #:use-module (gnu services dbus)
   #:use-module (gnu services shepherd)
   #:use-module (gnu system shadow)
   #:use-module (gnu packages admin)
@@ -69,6 +72,22 @@ 
 
             wireguard-service-type))
 
+;;;
+;;; Bitmask VPN
+;;;
+
+(define-public bitmask-service-type
+  (service-type
+   (name 'bitmask)
+   (description "Setup the @uref{https://bitmask.net, Bitmask} VPN application.")
+   (default-value bitmask)
+   (extensions
+    (list
+     ;; To configure polkit policy of bitmask.
+     (service-extension polkit-service-type list)
+     ;; To add bitmask to the system profile.
+     (service-extension profile-service-type list)))))
+
 ;;;
 ;;; OpenVPN.
 ;;;