diff mbox series

[bug#49286,1/1] gnu: Add emacs-ripgrep.

Message ID 20210630072911.28038-1-contact@dhruvin.dev
State Accepted
Headers show
Series Add emacs-ripgrep. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Dhruvin Gandhi June 30, 2021, 7:29 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ripgrep): New variable.
---
 gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Nicolas Goaziou July 2, 2021, 7:23 a.m. UTC | #1
Hello,

Dhruvin Gandhi via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ripgrep): New variable.

I removed #t from a phase and applied your patch.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d8c1f86207..bf0ab5910d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -99,6 +99,7 @@ 
 ;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
 ;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021 David Dashyan <mail@davie.li>
+;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4404,6 +4405,37 @@  column by drawing a thin line down the length of the editing window.")
 result.")
     (license license:gpl3+)))
 
+(define-public emacs-ripgrep
+  (package
+    (name "emacs-ripgrep")
+    (version "0.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nlamirault/ripgrep.el")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1a5rdpmvsgsjlc9sywism9pq7jd6n9qbcdsvpbfkq1npwhpifkbj"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("ripgrep" ,ripgrep)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; The repository contains both ripgrep and projectile-ripgrep
+         ;; packages. The latter has been merged into projectile itself.
+         (add-after 'unpack 'delete-projectile-ripgrep
+           (lambda _
+             (delete-file "projectile-ripgrep.el")
+             #t)))))
+    (home-page "https://github.com/nlamirault/ripgrep.el")
+    (synopsis "Search using ripgrep from inside Emacs")
+    (description "@code{ripgrep} is an Emacs search package based on the
+@code{ripgrep} command line tool.")
+    (license license:gpl2+)))
+
 (define-public emacs-rg
   (package
     (name "emacs-rg")