diff mbox series

[bug#49052] gnu: Add xkb-switch package

Message ID 87k0mv2cy2.fsf@posteo.net
State Accepted
Headers show
Series [bug#49052] gnu: Add xkb-switch package | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund June 15, 2021, 6:35 p.m. UTC

Comments

Nicolas Goaziou June 18, 2021, 10:09 a.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> From 97c9252c653212927c3e0f09f0095ff83e354544 Mon Sep 17 00:00:00 2001
> From: Niklas Eklund <niklas.eklund@posteo.net>
> Date: Tue, 15 Jun 2021 20:34:12 +0200
> Subject: [PATCH] gnu: Add xkb-switch.

Thank you. I applied your patch, with the following changes:

- I completed the commit message,
- I re-ordered inputs alphabetically,
- I added a comment explaining why tests were disabled,
- I removed the "allows to" from the description.

Regards,
diff mbox series

Patch

From 97c9252c653212927c3e0f09f0095ff83e354544 Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Tue, 15 Jun 2021 20:34:12 +0200
Subject: [PATCH] gnu: Add xkb-switch.

---
 gnu/packages/xdisorg.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 5573e2afb5..c9353bf99e 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -46,6 +46,7 @@ 
 ;;; Copyright © 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;; Copyright © 2021 Renzo Poddighe <renzo@poddighe.nl>
+;;; Copyright © 2021 Niklas Eklund <niklas.eklund@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -358,6 +359,31 @@  high-level and flexible remapping mechanisms.  It affects the low-level
 layers (evdev and uinput), making remapping work in almost all the places.")
     (license license:gpl3+)))           ; see README.md (no licence headers)
 
+(define-public xkb-switch
+  (package
+    (name "xkb-switch")
+    (version "1.8.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference (url "https://github.com/grwlf/xkb-switch")
+                           (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1sd6ihgsswp6hjm1i4y092n4gl3gj0bc22grz4n7iy43mwphi40d"))))
+    (build-system cmake-build-system)
+    (inputs `(("libxkbfile" ,libxkbfile)
+              ("libx11" ,libx11)))
+    (arguments
+     `(#:tests? #f))
+    (home-page "https://github.com/grwlf/xkb-switch")
+    (synopsis "Switch your X keyboard layouts from the command line")
+    (description
+     "xkb-switch is a C++ program that allows to query and change the XKB layout state.")
+    (license license:gpl3+)))
+
+
 (define-public xclip
   (package
     (name "xclip")
-- 
2.31.1