diff mbox series

[bug#49054] Add borg-sans-mono Font

Message ID bAJGGQKCmz8woyPWArWQO7pfI-4dvQSu4dRtfm2YymkzUHTiUn59ZrNuUA-K6RcA86t8Faeey2CcBbOBJQZ_E8JAyAbf3re5ZvyKFnf3t-I=@protonmail.com
State Accepted
Headers show
Series [bug#49054] Add borg-sans-mono Font | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Charles June 16, 2021, 12:53 a.m. UTC
This is my first contribution, so let me know if I did something wrong. The patch is attatched.

Comments

Leo Prikler June 16, 2021, 6:33 a.m. UTC | #1
Am Mittwoch, den 16.06.2021, 00:53 +0000 schrieb Charles:
> This is my first contribution, so let me know if I did something
> wrong. The patch is attatched.

> > Subject: [PATCH] gnu: Add font-borg-sans-mono
> > 
> > * gnu/packages/fonts.scm (font-borg-sans-mono): Add font
Nitpicky, but the dot in the headerline is missing and we usually
denote new packages by "new variable" since that's what they are on
Scheme level.

> +    (name "font-borg-sans-mono")
> +    (version "0.3.0")
> +    (home-page "https://github.com/charje/borg-sans-mono")
home-page usually comes after build-system+arguments.

> +       (uri (string-append
> +             home-page
> +             "/releases/download/v"
> +             version
> +             "/borg-sans-mono.zip"))
Please type out home-page.  It could very well be, that the devs start
some fancy Github Pages website, which would break this code.

> +    (description "Droid Sans Mono Slashed + Hasklig-style
> ligatures!")
This is not very descriptive at all, I'm afraid.  If Hasklig or Monoid
are a reasonable alternative to this font, it's probably easier to find
a description for them.

Regards,
Leo
diff mbox series

Patch

From 8027b937d0e91df7eb552a6388e977414fb36b94 Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Tue, 15 Jun 2021 19:40:58 -0500
Subject: [PATCH] gnu: Add font-borg-sans-mono

* gnu/packages/fonts.scm (font-borg-sans-mono): Add font
---
 gnu/packages/fonts.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 973393acc4..8fb8ec102e 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2175,3 +2175,22 @@  neighborhood of Buenos Aires inspired Julieta Ulanovsky to design this
 typeface and rescue the beauty of urban typography that emerged in the first
 half of the twentieth century.")
     (license license:silofl1.1)))
+
+(define-public font-borg-sans-mono
+  (package
+    (name "font-borg-sans-mono")
+    (version "0.3.0")
+    (home-page "https://github.com/charje/borg-sans-mono")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             home-page
+             "/releases/download/v"
+             version
+             "/borg-sans-mono.zip"))
+       (sha256 (base32 "1jxscrbmqbz3zgfgv6q2ip4482ciwz2xpm460llacsdiyy63abfb"))))
+    (build-system font-build-system)
+    (synopsis "The Borg Sans Mono font")
+    (description "Droid Sans Mono Slashed + Hasklig-style ligatures!")
+    (license license:asl2.0)))
-- 
2.32.0