diff mbox series

[bug#48382,1/6] gnu: yml2: Update to 2.7.0.

Message ID 9f40b4002667ba7c9e83f4c9aab84b7a88e94a19.1620840984.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#48382,1/6] gnu: yml2: Update to 2.7.0. | expand

Commit Message

Hartmut Goebel May 12, 2021, 5:39 p.m. UTC
* gnu/packages/pep.scm (yml2): Update to 2.7.0.
  [source]: Switch to new git repo.
---
 gnu/packages/pep.scm | 19 ++++++++++---------
 1 file changed, 10 insertions(+), 9 deletions(-)

Comments

Hartmut Goebel May 31, 2021, 8:47 a.m. UTC | #1
Pushed as c85edf2ca47a10634faba15848cca7b4558a82ab
diff mbox series

Patch

diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index 289796a377..6d24534f7e 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -1,5 +1,5 @@ 
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016, 2020, 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -40,15 +40,16 @@ 
 (define-public yml2
   (package
     (name "yml2")
-    (version "2.6.3")
-    (source (origin
-       (method hg-fetch)
-       (uri (hg-reference
-             (url "https://pep.foundation/dev/repos/yml2")
-             (changeset version)))
-       (file-name (string-append name "-" version "-checkout"))
+    (version "2.7.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitea.pep.foundation/fdik/yml2")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "10jjjyq1mz18zkzvxd62aba00h69gd9cglisqcvb81j67ml2v1bx"))))
+        (base32 "0fm1x1fv4lwcpbn59s55idzf7x173n59xpz8rlrxalmi6gvsjijr"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-lxml" ,python-lxml)))