diff mbox series

[bug#48287] gnu: Add guile-raw-strings.

Message ID 97bc884cb5366248ad26aaac6a4c573a4a159a7d.1620482502.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#48287] gnu: Add guile-raw-strings. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen May 8, 2021, 2:01 p.m. UTC
* gnu/packages/guile-xyz.scm (guile-raw-strings): New variable.
---
 gnu/packages/guile-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: e5adaf6c2de917f33f90e24b551a8991e55b3eb6

Comments

M May 8, 2021, 9:18 p.m. UTC | #1
> +           (add-after 'build 'check
> +             (lambda _
> +               (invoke "guile" "-L" "." "-s" "test.scm"))))))

To support "guix build --without-tests", make this

> +           (add-after 'build 'check
> +             (lambda* (#:key tests? #:allow-other-keys)
> +               (when tests?
> +                 (invoke "guile" "-L" "." "-s" "test.scm")))))))

Greetings,Maxime.
Xinglu Chen May 9, 2021, 8:12 a.m. UTC | #2
On Sat, May 08 2021, Maxime Devos wrote:

>> +           (add-after 'build 'check
>> +             (lambda _
>> +               (invoke "guile" "-L" "." "-s" "test.scm"))))))
>
> To support "guix build --without-tests", make this
>
>> +           (add-after 'build 'check
>> +             (lambda* (#:key tests? #:allow-other-keys)
>> +               (when tests?
>> +                 (invoke "guile" "-L" "." "-s" "test.scm")))))))

Thanks for taking a look. :)
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index f908fb8a3b..f596defe44 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2106,6 +2106,37 @@  microAdapton.  Both miniAdapton and microAdapton are designed to be easy to
 understand, extend, and port to host languages other than Scheme.")
       (license license:expat))))
 
+(define-public guile-raw-strings
+  (let ((commit "aa1cf783f2542811b473f797e12490920b779baa")
+        (revision "0"))
+    (package
+      (name "guile-raw-strings")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/lloda/guile-raw-strings")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1r2gx86zw5hb6byllra3nap3fw9p7q7rvdmg6qn9myrdxyjpns3l"))))
+      (build-system guile-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'build 'check
+             (lambda _
+               (invoke "guile" "-L" "." "-s" "test.scm"))))))
+      (native-inputs
+       `(("guile" ,guile-3.0)))
+      (home-page "https://github.com/lloda/guile-raw-strings")
+      (synopsis "Guile reader extension for `raw strings'")
+      (description "This package provides A Guile reader extension for `raw
+strings', it lets you write verbatim strings without having to escape double
+quotes. ")
+      (license license:public-domain))))
+
 (define-public guile-reader
   (package
     (name "guile-reader")