diff mbox series

[bug#47615,v2,09/12] gnu: mercurial: Skip tests on powerpc-linux.

Message ID d16f5020e8e0d80af7e5b0618b4d1ee0628e3ca0.1619076704.git.efraim@flashner.co.il
State Accepted
Headers show
Series Add 32-bit powerpc support | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner April 22, 2021, 7:59 a.m. UTC
* gnu/packages/version-control.scm (mercurial)[arguments]: Skip tests on
powerpc-linux.
---
 gnu/packages/version-control.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Unchanged since last patchset, IMO not ready for upstreaming.

Comments

M April 22, 2021, 4:41 p.m. UTC | #1
Efraim Flashner schreef op do 22-04-2021 om 10:59 [+0300]:
> * gnu/packages/version-control.scm (mercurial)[arguments]: Skip tests on
> powerpc-linux.
> ---
>  gnu/packages/version-control.scm | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
> 
> Unchanged since last patchset, IMO not ready for upstreaming.
> 
> diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
> index 4d4b276a10..13e2ccd400 100644
> --- a/gnu/packages/version-control.scm
> +++ b/gnu/packages/version-control.scm
> @@ -1688,7 +1688,11 @@ execution of any hook written in any language before every commit.")
>                           "--slowtimeout" "86400"
>                           ;; The test suite takes a long time and produces little
>                           ;; output by default.  Prevent timeouts due to silence.
> -                         "-v"))))))))
> +                         "-v"))))))
> +       ;; Tests on powerpc-linux take more than 10 hours.
> +       #:tests? ,(if (string=? "powerpc-linux" (or (%current-system)
> +                                                   (%current-target-system)))
> +                   '#f '#t)))

You can remove ' in '#f and '#t here.
That shouldn't cause a derivation change.
Keeping ' is harmless though, it's just superfluous.
Likewise for some other commits.

I'm not really familiar with powerpc and the packages you modified,
so I'm just looking at style, and cross-compilation issues (which you seem
to have covered).

Greetings,
Maxime.
Ludovic Courtès May 6, 2021, 2:51 p.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> skribis:

> Efraim Flashner schreef op do 22-04-2021 om 10:59 [+0300]:
>> * gnu/packages/version-control.scm (mercurial)[arguments]: Skip tests on
>> powerpc-linux.
>> ---
>>  gnu/packages/version-control.scm | 6 +++++-
>>  1 file changed, 5 insertions(+), 1 deletion(-)
>> 
>> Unchanged since last patchset, IMO not ready for upstreaming.
>> 
>> diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
>> index 4d4b276a10..13e2ccd400 100644
>> --- a/gnu/packages/version-control.scm
>> +++ b/gnu/packages/version-control.scm
>> @@ -1688,7 +1688,11 @@ execution of any hook written in any language before every commit.")
>>                           "--slowtimeout" "86400"
>>                           ;; The test suite takes a long time and produces little
>>                           ;; output by default.  Prevent timeouts due to silence.
>> -                         "-v"))))))))
>> +                         "-v"))))))
>> +       ;; Tests on powerpc-linux take more than 10 hours.
>> +       #:tests? ,(if (string=? "powerpc-linux" (or (%current-system)
>> +                                                   (%current-target-system)))
>> +                   '#f '#t)))
>
> You can remove ' in '#f and '#t here.

You can even write:

  #:tests? (not (string-prefix? "powerpc-" (or …)))

Note: use ‘string-prefix?’ because ‘%current-target-system’ returns a
triplet, not a “system type”.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 4d4b276a10..13e2ccd400 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1688,7 +1688,11 @@  execution of any hook written in any language before every commit.")
                          "--slowtimeout" "86400"
                          ;; The test suite takes a long time and produces little
                          ;; output by default.  Prevent timeouts due to silence.
-                         "-v"))))))))
+                         "-v"))))))
+       ;; Tests on powerpc-linux take more than 10 hours.
+       #:tests? ,(if (string=? "powerpc-linux" (or (%current-system)
+                                                   (%current-target-system)))
+                   '#f '#t)))
     ;; The following inputs are only needed to run the tests.
     (native-inputs
      `(("python-nose" ,python-nose)