diff mbox series

[bug#47756] gnu: guile-git: Update to 0.5.0.

Message ID 9456fb365b313b1553317db1cccdedcf58e29182.1618340546.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#47756] gnu: guile-git: Update to 0.5.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 13, 2021, 7:22 p.m. UTC
* gnu/packages/guile.scm (guile-git): Update to 0.5.0.
[source]: Use ‘git-fetch’ instead of ‘url-fetch’.
[native-inputs]: Add autoconf, automake, and texinfo.
---
I used ‘git-fetch’ because it is more flexible than ‘url-fetch’, users
can for example use package transformations to easily use a desired
commit/branch.  Because the distributed tarball includes files that are
generated by running ‘./configure’, users would then have to manually
add some native-inputs to make it build with a custom version of the
package (this has happened to me a few times).

 gnu/packages/guile.scm | 15 +++++++++------
 1 file changed, 9 insertions(+), 6 deletions(-)


base-commit: 82543e9649da2da9a5285ede4ec4f718fd740fcb

Comments

Ludovic Courtès April 13, 2021, 9:31 p.m. UTC | #1
Hi!

I pushed that update independently as
c2e83b71054f953953711e027f863d6c75c6ddb2.

Xinglu Chen <public@yoctocell.xyz> skribis:

> * gnu/packages/guile.scm (guile-git): Update to 0.5.0.
> [source]: Use ‘git-fetch’ instead of ‘url-fetch’.
> [native-inputs]: Add autoconf, automake, and texinfo.
> ---
> I used ‘git-fetch’ because it is more flexible than ‘url-fetch’, users
> can for example use package transformations to easily use a desired
> commit/branch.

I agree this is desirable.  I didn’t do that because I thought it might
be a case where we need Guile-Git for ‘git-fetch’, but I think I was
wrong (I was confusing with Guile-Zlib, which we cannot obtain via
‘git-fetch’ because ‘git-fetch’ uses it.)

So after all, maybe we can use ‘git-fetch’?

Ludo’.
Xinglu Chen April 14, 2021, 12:53 p.m. UTC | #2
On Tue, Apr 13 2021, Ludovic Courtès wrote:

> Hi!
>
> I pushed that update independently as
> c2e83b71054f953953711e027f863d6c75c6ddb2.

Oh, cool.

>> I used ‘git-fetch’ because it is more flexible than ‘url-fetch’, users
>> can for example use package transformations to easily use a desired
>> commit/branch.
>
> I agree this is desirable.  I didn’t do that because I thought it might
> be a case where we need Guile-Git for ‘git-fetch’, but I think I was
> wrong (I was confusing with Guile-Zlib, which we cannot obtain via
> ‘git-fetch’ because ‘git-fetch’ uses it.)

Yeah, ‘git-fetch’ in (guix build git) runs (invoke "git" args ...), it
doesn’t seem to have any dependency on Guile-Git.

> So after all, maybe we can use ‘git-fetch’?

I think that would a good idea. :)
Ludovic Courtès April 16, 2021, 9:54 p.m. UTC | #3
Xinglu Chen <public@yoctocell.xyz> skribis:

> On Tue, Apr 13 2021, Ludovic Courtès wrote:
>
>> Hi!
>>
>> I pushed that update independently as
>> c2e83b71054f953953711e027f863d6c75c6ddb2.
>
> Oh, cool.
>
>>> I used ‘git-fetch’ because it is more flexible than ‘url-fetch’, users
>>> can for example use package transformations to easily use a desired
>>> commit/branch.
>>
>> I agree this is desirable.  I didn’t do that because I thought it might
>> be a case where we need Guile-Git for ‘git-fetch’, but I think I was
>> wrong (I was confusing with Guile-Zlib, which we cannot obtain via
>> ‘git-fetch’ because ‘git-fetch’ uses it.)
>
> Yeah, ‘git-fetch’ in (guix build git) runs (invoke "git" args ...), it
> doesn’t seem to have any dependency on Guile-Git.
>
>> So after all, maybe we can use ‘git-fetch’?
>
> I think that would a good idea. :)

Done in 7a6625e83f68f6408ff0a82b12e7a95c6b0cc096!

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 0dad390275..76741504c8 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -776,21 +776,24 @@  type system, elevating types to first-class status.")
 (define-public guile-git
   (package
     (name "guile-git")
-    (version "0.4.0")
+    (version "0.5.0")
     (home-page "https://gitlab.com/guile-git/guile-git.git")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://gitlab.com/guile-git/guile-git/uploads/"
-                                  "2600bb0dfdfb00bfbe46811dccad51d8/guile-git-"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/guile-git/guile-git")
+                    (commit (string-append "v" version))))
               (sha256
                (base32
-                "1kxyg9x2aa1pg69cl48wysq0pbxvwfahy1xpl5ab6p8babhf7kic"))))
+                "1hqw3jy81cnsgybsbnfvwvhv1bajwq662hikkrr6dcgky6yspsxx"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags '("GUILE_AUTO_COMPILE=0")))     ; to prevent guild warnings
     (native-inputs
      `(("pkg-config" ,pkg-config)
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("texinfo" ,texinfo)
        ("guile" ,guile-3.0)
        ("guile-bytestructures" ,guile-bytestructures)))
     (inputs