diff mbox series

[bug#47467] : Fix Blender missing Voxel Remesher

Message ID BNJM6sgD3qkQEnMpN5ovpwdbPTX2yKVDoJDsFe1MjZRD3tzcxc_1IY5ynTIwFBiFmOpa_9_dRv0h56lq4AXiB94eKAK4nwu9HC801em-EsM=@elenq.tech
State Accepted
Headers show
Series [bug#47467] : Fix Blender missing Voxel Remesher | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ekaitz Zarraga March 29, 2021, 2:17 p.m. UTC
Hi,

According to bug#47463[^1], Blender is missing a dependency that
doesn't allow to run the Voxel Remesher.

This series of patches solve that.

I have a comment on the first one. I'm not sure if I did it right.

I don't see a better way to set the `rpath` correcty. It should
find the lib by itself but the package has an executable as
ouput that doesn't find the library the package itself generates.
Removing the extra phase I added shows the RPATH is set to `lib`
instead to the absolute path of the library so the runpath check
fails to execute.

This is the best way I found to solve that but I'm sure whoever
that gets this patch knows a better way to handle that.

I tested Blender with this and it runs the Voxel Remesher as
expected.

Please, don't hesitate to send me any comment.

Thanks!


[^1]: https://lists.gnu.org/archive/html/bug-guix/2021-03/msg00647.html

Comments

Ricardo Wurmus April 12, 2021, 2:14 p.m. UTC | #1
I pushed a slightly modified version of your openvdb addition to the
“master” branch.

As for the second patch, I think it would be good to leave off the
addition of libxxf86vm, because it seems that it’s unrelated to enabling
the voxel remesher feature.

If you could confirm that, I’d be happy to apply a modified second
patch.  The commit message for that second patch should list the actual
changes like this:

--8<---------------cut here---------------start------------->8---
gnu: blender: Add and enable support for OpenVDB and TBB.

* gnu/packages/graphics.scm (blender)[arguments]: Enable OpenVDB and TBB.
[inputs]: Add openvdb.
--8<---------------cut here---------------end--------------->8---

Thanks for working on this!
Ekaitz Zarraga April 21, 2021, 3:36 p.m. UTC | #2
Hi,

Sorry for the delay.

As I told Ricardo on IRC, I'm going to review all the inputs of
the package Blender because the official installation guide
proposes some inputs that we are not including specifically.

Until I do that, I'm compiling blender with the minimum changes
to make the voxel remesher work and I'll append the minimum patch
to this issue when it compiles (1h or so) and I test it.

Thanks for your time,
Ekaitz
diff mbox series

Patch

From 630ebdeec1b8524d09c811ac93dbbe46d31daa45 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Mon, 29 Mar 2021 16:05:04 +0200
Subject: [PATCH 2/2] gnu: blender: Update dependencies

    * gnu/packages/graphics.scm (blender): Add dependencies and flags
---
 gnu/packages/graphics.scm | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index b4df9f5c04..ddf6a6c2ba 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -534,6 +534,8 @@  volumetric applications typically encountered in feature film production.")
                "-DWITH_INSTALL_PORTABLE=OFF"
                "-DWITH_JACK=ON"
                "-DWITH_MOD_OCEANSIM=ON"
+               "-DWITH_OPENVDB=ON"
+               "-DWITH_TBB=ON"
                "-DWITH_OPENSUBDIV=ON"
                "-DWITH_PYTHON_INSTALL=OFF"
                (string-append "-DPYTHON_LIBRARY=python" ,python-version)
@@ -589,6 +591,8 @@  volumetric applications typically encountered in feature film production.")
        ("pugixml" ,pugixml)
        ("python" ,python)
        ("python-numpy" ,python-numpy)
+       ("openvdb" ,openvdb)
+       ("libxxf86vm" ,libxxf86vm)
        ("tbb" ,tbb)
        ("zlib" ,zlib)
        ("embree" ,embree)))
-- 
2.31.0