diff mbox series

[bug#47466] scripts: import: cran: Add missing help for 'style' option.

Message ID 20210329131117.6592-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#47466] scripts: import: cran: Add missing help for 'style' option. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 29, 2021, 1:11 p.m. UTC
* guix/scripts/import/cran.scm (show-help): Add help message for 'style'
option.
---
 guix/scripts/import/cran.scm | 3 +++
 1 file changed, 3 insertions(+)

Comments

Christopher Baines March 29, 2021, 6:57 p.m. UTC | #1
zimoun <zimon.toutoune@gmail.com> writes:

> * guix/scripts/import/cran.scm (show-help): Add help message for 'style'
> option.
> ---
>  guix/scripts/import/cran.scm | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/guix/scripts/import/cran.scm b/guix/scripts/import/cran.scm
> index 4767bc082d..466d0cb8e2 100644
> --- a/guix/scripts/import/cran.scm
> +++ b/guix/scripts/import/cran.scm
> @@ -50,6 +50,9 @@ Import and convert the CRAN package for PACKAGE-NAME.\n"))
>    (display (G_ "
>    -r, --recursive        import packages recursively"))
>    (display (G_ "
> +  -s SPECIFICATIONS, --style=SPECIFICATIONS
> +                         specify package specifications instead of references"))
> +  (display (G_ "
>    -V, --version          display version information and exit"))
>    (newline)
>    (show-bug-report-information))

I changed the message, and pushed this as
55c25ee4c5cee0707c94f773eb7d1686f79cff75.

+  -s, --style=STYLE      choose output style, either specification or variable"))

In my view, the thing in caps is a placeholder, so I put STYLE rather
than SPECIFICATIONS, I also altered the message to hint at what this
controls (the output), and the supported values.

Thanks,

Chris
diff mbox series

Patch

diff --git a/guix/scripts/import/cran.scm b/guix/scripts/import/cran.scm
index 4767bc082d..466d0cb8e2 100644
--- a/guix/scripts/import/cran.scm
+++ b/guix/scripts/import/cran.scm
@@ -50,6 +50,9 @@  Import and convert the CRAN package for PACKAGE-NAME.\n"))
   (display (G_ "
   -r, --recursive        import packages recursively"))
   (display (G_ "
+  -s SPECIFICATIONS, --style=SPECIFICATIONS
+                         specify package specifications instead of references"))
+  (display (G_ "
   -V, --version          display version information and exit"))
   (newline)
   (show-bug-report-information))