diff mbox series

[bug#47395] Bump SQLite to 3.35.2

Message ID pEQvSTi-vkTNeb5iQSFCWAfzjS2kCUdro040nTlOmrHP0I6J3n-SyrP8yuNrRffQsWEdPYQJJK9adtqOCs9q9oW-DUxD1ldRFSZzg5Grffw=@pm.me
State New
Headers show
Series [bug#47395] Bump SQLite to 3.35.2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Isaac Young March 25, 2021, 6:39 p.m. UTC
Hello,

Fossil 2.14 needs SQLite 3.33.0 or later, so I'd like to update the SQLite package to the latest version.

Cheers,
Isaac Young

Comments

Léo Le Bouter March 25, 2021, 7:38 p.m. UTC | #1
On Thu, 2021-03-25 at 18:39 +0000, Isaac Young via Guix-patches via
wrote:
> Hello,

Hello!

> Fossil 2.14 needs SQLite 3.33.0 or later, so I'd like to update the
> SQLite package to the latest version.

Thank you for the patch! Unfortunately we can't just do that because it
would cause lots of rebuilds, sqlite is already 3.34.x on the core-
updates branch and I was about to update it to 3.35.2 like you did.

We will merge core-updates at some point after the 1.2.1 release, it's
long overdue. However you can always create a package variant like
sqlite-3.35 for fossil only until we update the primary sqlite package.

> Cheers,
> Isaac Young

Léo
Jelle Licht May 29, 2023, 10:50 a.m. UTC | #2
Closing this, as we now have sqlite packages for versions 3.40.0 and
3.39.3 on master.
diff mbox series

Patch

From b9f4648e9deacd487f202dd77a34e809ba14ffa9 Mon Sep 17 00:00:00 2001
From: Isaac Young <isyoung@pm.me>
Date: Thu, 25 Mar 2021 12:27:22 -0600
Subject: [PATCH] Updating SQLite to version 3.35.2

---
 gnu/packages/sqlite.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/sqlite.scm b/gnu/packages/sqlite.scm
index eeb77749d8..53e98b2389 100644
--- a/gnu/packages/sqlite.scm
+++ b/gnu/packages/sqlite.scm
@@ -48,7 +48,7 @@ 
 (define-public sqlite
   (package
    (name "sqlite")
-   (version "3.31.1")
+   (version "3.35.2")
    (source (origin
             (method url-fetch)
             (uri (let ((numeric-version
@@ -60,11 +60,11 @@ 
                                             (map (cut string-pad <> 2 #\0)
                                                  other-digits))
                                            6 #\0))))))
-                   (string-append "https://sqlite.org/2020/sqlite-autoconf-"
+                   (string-append "https://sqlite.org/2021/sqlite-autoconf-"
                                   numeric-version ".tar.gz")))
             (sha256
              (base32
-              "1bj936svd8i5g25xd1bj52hj4zca01fgl3sqkj86z9q5pkz4wa32"))))
+              "1bfczv5006ycwr1vw7xbq7cmys0jvfr8awmx7wi1b40zyj0yss8j"))))
    (build-system gnu-build-system)
    (inputs `(("readline" ,readline)))
    (native-inputs (if (hurd-target?)
-- 
2.31.0