diff mbox series

[bug#47213,v2] doc: Add snippet for running 'guix refresh' on installed

Message ID 239f5ab21f9d39a00b71963b127e2745969e44cf.1615983540.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#47213,v2] doc: Add snippet for running 'guix refresh' on installed | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen March 17, 2021, 12:23 p.m. UTC
* doc/guix.texi (Invoking guix refresh): Add snippet that runs 'guix refresh'
on all the packages installed in the current profile.
---
Changes since v1:
- Correct the example snippet.
- Refer the reader to "Running Guix Before It Is Installed".
- Add suggestion to run `guix package -i --with-latest`.

 doc/guix.texi | 18 ++++++++++++++++--
 1 file changed, 16 insertions(+), 2 deletions(-)


base-commit: 109f58444beecd1b9b7c502f2a687a6b91c62dc0

Comments

Xinglu Chen March 25, 2021, 4:15 p.m. UTC | #1
On Wed, Mar 17 2021, Xinglu Chen wrote:

> * doc/guix.texi (Invoking guix refresh): Add snippet that runs 'guix refresh'
> on all the packages installed in the current profile.

Friendly ping! :)

I just realized that I started a new bug with the v2 patch, apologies
for the mess I have created.
Ludovic Courtès March 25, 2021, 11:21 p.m. UTC | #2
Hi!

Xinglu Chen <public@yoctocell.xyz> skribis:

> * doc/guix.texi (Invoking guix refresh): Add snippet that runs 'guix refresh'
> on all the packages installed in the current profile.
> ---
> Changes since v1:
> - Correct the example snippet.
> - Refer the reader to "Running Guix Before It Is Installed".
> - Add suggestion to run `guix package -i --with-latest`.
>
>  doc/guix.texi | 18 ++++++++++++++++--
>  1 file changed, 16 insertions(+), 2 deletions(-)
>
> diff --git a/doc/guix.texi b/doc/guix.texi
> index 410670e639..d94772d5be 100644
> --- a/doc/guix.texi
> +++ b/doc/guix.texi
> @@ -87,6 +87,7 @@
>  Copyright @copyright{} 2020 John Soo@*
>  Copyright @copyright{} 2020 Jonathan Brielmaier@*
>  Copyright @copyright{} 2020 Edgar Vincent@*
> +Copyright @copyright{} 2021 Xinglu Chen@*
>  
>  Permission is granted to copy, distribute and/or modify this document
>  under the terms of the GNU Free Documentation License, Version 1.3 or
> @@ -11719,8 +11720,21 @@
>  
>  @noindent
>  The command above specifically updates the @code{emacs} and
> -@code{idutils} packages.  The @option{--select} option would have no
> -effect in this case.
> +@code{idutils} packages (see @pxref{Running Guix Before It Is
> +Installed}).  The @option{--select} option would have no effect in this
> +case.
> +
> +You can also quickly update all the packages installed in the current
> +profile with the following snippet:
> +
> +@example
> +$ ./pre-inst-env guix refresh -u $(guix package --list-installed | cut -f1)
> +@end example
> +
> +This is handy if you don't use manifests for installing packages into
> +your profile.  If you just want to install the latest version of a
> +package, run @command{guix package -i --with-latest} (see @pxref{Package
> +Transformation Options}).

I pushed a variant of this as commit
3cb1136780108aebe45794e639b4a8c06460c7e3 and related commits.

Thank you, and apologies for the delay!

Ludo’.
diff mbox series

Patch

diff --git a/doc/guix.texi b/doc/guix.texi
index 410670e639..d94772d5be 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -87,6 +87,7 @@ 
 Copyright @copyright{} 2020 John Soo@*
 Copyright @copyright{} 2020 Jonathan Brielmaier@*
 Copyright @copyright{} 2020 Edgar Vincent@*
+Copyright @copyright{} 2021 Xinglu Chen@*
 
 Permission is granted to copy, distribute and/or modify this document
 under the terms of the GNU Free Documentation License, Version 1.3 or
@@ -11719,8 +11720,21 @@ 
 
 @noindent
 The command above specifically updates the @code{emacs} and
-@code{idutils} packages.  The @option{--select} option would have no
-effect in this case.
+@code{idutils} packages (see @pxref{Running Guix Before It Is
+Installed}).  The @option{--select} option would have no effect in this
+case.
+
+You can also quickly update all the packages installed in the current
+profile with the following snippet:
+
+@example
+$ ./pre-inst-env guix refresh -u $(guix package --list-installed | cut -f1)
+@end example
+
+This is handy if you don't use manifests for installing packages into
+your profile.  If you just want to install the latest version of a
+package, run @command{guix package -i --with-latest} (see @pxref{Package
+Transformation Options}).
 
 When considering whether to upgrade a package, it is sometimes
 convenient to know which packages would be affected by the upgrade and