diff mbox series

[bug#46445] tests: Make the STORE test more robust in a "pure" environment.

Message ID 2cd34bbd26f480faeb89f38af590d10339303f8f.1613075074.git.leo@famulari.name
State Accepted
Headers show
Series [bug#46445] tests: Make the STORE test more robust in a "pure" environment. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Feb. 11, 2021, 8:25 p.m. UTC
Otherwise, the test crashes (not fails) when run in `guix environment --pure guix`.

I'm not sure this is the right approach, when I look at commit
3d43017026f9995ad128915db8ca5eafe061bf75, which added this variable.

* tests/store.scm (%shell): Fallback to "/bin/sh".
---
 tests/store.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Leo Famulari Feb. 25, 2021, 8:13 p.m. UTC | #1
Ping!

Is this change correct?
Ludovic Courtès March 17, 2021, 9:36 p.m. UTC | #2
Leo Famulari <leo@famulari.name> skribis:

> Otherwise, the test crashes (not fails) when run in `guix environment --pure guix`.
>
> I'm not sure this is the right approach, when I look at commit
> 3d43017026f9995ad128915db8ca5eafe061bf75, which added this variable.
>
> * tests/store.scm (%shell): Fallback to "/bin/sh".

LGTM, thanks!

Ludo'.
Leo Famulari March 18, 2021, 7:16 p.m. UTC | #3
On Wed, Mar 17, 2021 at 10:36:16PM +0100, Ludovic Courtès wrote:
> LGTM, thanks!

Thanks for your review! Pushed as
0d8d499036f632e03f63bdaf36b02861ea52b3e6
diff mbox series

Patch

diff --git a/tests/store.scm b/tests/store.scm
index cda0e0302f..9c25adf5e9 100644
--- a/tests/store.scm
+++ b/tests/store.scm
@@ -50,7 +50,7 @@ 
   (open-connection-for-tests))
 
 (define %shell
-  (or (getenv "SHELL") (getenv "CONFIG_SHELL")))
+  (or (getenv "SHELL") (getenv "CONFIG_SHELL") "/bin/sh"))
 
 
 (test-begin "store")