diff mbox series

[bug#47114] gnu: Add emacs-elfeed-score.

Message ID 6bc3349069e0f337284aa2600d4f4a57a08ca674.1615586153.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#47114] gnu: Add emacs-elfeed-score. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen March 12, 2021, 9:56 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-elfeed-score): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 5a06b83fc92710c5846a83bbf49f0ea84c8ecec2

Comments

Nicolas Goaziou March 13, 2021, 12:51 p.m. UTC | #1
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

> * gnu/packages/emacs-xyz.scm (emacs-elfeed-score): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0bf744e1cf..dfe66d778c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9048,6 +9048,32 @@  duplicated a lot.  Org-mode makes the book keeping of tags and feeds
 much easier.")
       (license license:gpl3+))))
 
+(define-public emacs-elfeed-score
+  (package
+    (name "emacs-elfeed-score")
+    (version "0.7.7")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/sp1ff/elfeed-score")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "07xid0a31ghknbfwj8dxzbqkg4sfayjhlqvp17p2bzlf1mj0zjyd"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-elfeed" ,emacs-elfeed)))
+    (home-page "https://github.com/sp1ff/elfeed-score")
+    (synopsis "Gnus-style scoring for Elfeed")
+    (description "@code{elfeed-score} is an add-on for Elfeed, an RSS reader
+for Emacs.  It brings Gnus-style scoring to your RSS feeds.  Elfeed, by
+default, displays feed entries by date.  This package allows you to setup
+rules for assigning numeric scores to entries, and sorting entries with higher
+scores ahead of those with lower, regardless of date.  The idea is to
+prioritize content important to you.")
+    (license license:gpl3+)))
+
 (define-public emacs-el-x
   (package
     (name "emacs-el-x")