diff mbox series

[bug#46572] gnu: Add usync.

Message ID 20210216221522.822909-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#46572] gnu: Add usync. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör Feb. 16, 2021, 10:15 p.m. UTC
* gnu/packages/sync.scm (usync): New variable.
---
 gnu/packages/sync.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Ludovic Courtès March 2, 2021, 9:11 p.m. UTC | #1
Hi,

Stefan Reichör <stefan@xsteve.at> skribis:

> * gnu/packages/sync.scm (usync): New variable.

Applied, thanks!

zimoun <zimon.toutoune@gmail.com> skribis:

> The error you get comes from circular dependency, I guess.
> If you comment both 'unison' and '#:use-module (gnu packages ocaml)',
> then there is no backtrace.

This came from the reference to ‘llvm’ in commit
8f710cc598fb675d267f49a82cffc197f03ad52c.  Fixed now.

Thanks you & Léo for reporting it!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index f3d6e9013c..8715690483 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +26,7 @@ 
 (define-module (gnu packages sync)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system meson)
@@ -46,6 +48,7 @@ 
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
+  #:use-module (gnu packages ocaml)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -53,6 +56,7 @@ 
   #:use-module (gnu packages readline)
   #:use-module (gnu packages rsync)
   #:use-module (gnu packages selinux)
+  #:use-module (gnu packages shells)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tls))
@@ -315,6 +319,37 @@  comparatively easy to install not requiring new file systems or block devices
 and does not hamper local file system performance.")
     (license license:gpl2+)))
 
+(define-public usync
+  (let ((revision "1")
+        (commit "09a8059a1adc22666d3ecf7872e22e6846c3ac9e"))
+    (package
+      (name "usync")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ebzzry/usync")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "16i1q8f0jmfd43rb8d70l2b383vr5ib4kh7iq3yd345q7xjz9c2j"))))
+      (build-system copy-build-system)
+      (propagated-inputs
+       `(("scsh" ,scsh)
+         ("rsync" ,rsync)
+         ("unison" ,unison)))
+      (arguments
+       `(#:install-plan
+         '(("usync" "bin/usync"))))
+      (home-page "https://github.com/ebzzry/usync")
+      (synopsis "Command line site-to-site synchronization tool")
+      (description
+       "@command{usync} is a simple site-to-site synchronization program
+written in @command{scsh}.  It makes use of @command{unison} and
+@command{rsync} for bi- and uni-directional synchronizations.")
+      (license license:expat))))
+
 (define-public casync
   (package
     (name "casync")