diff mbox series

[bug#46680] gnu: Add midicomp.

Message ID 20210221102137.22967-1-alex@zrythm.org
State Accepted
Headers show
Series [bug#46680] gnu: Add midicomp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Alexandros Theodotou Feb. 21, 2021, 10:21 a.m. UTC
* gnu/packages/audio.scm (midicomp): New variable.
---
 gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Nicolas Goaziou Feb. 23, 2021, 5:47 p.m. UTC | #1
Hello,

Alexandros Theodotou <alex@zrythm.org> writes:

> * gnu/packages/audio.scm (midicomp): New variable.

Thank you. Some comments follow.

> +    (package
> +      (name "midicomp")
> +      (version (string-append "0.0.6-" revision "." (string-take commit 7)))

According to the README, the last version is 0.0.8. Also, the above
should be written more compactly

  (version (git-version "0.0.8" revision commit))

> +      (synopsis "MIDI compiler")

I suggest "Convert SMF MIDI files to and from plain text", which may be
more explicit.

> +      (license license:agpl3))))

I think there is an issue here. The repository has no LICENSE file, and
source code files have no license header. The only reference to AGPL3.0
is in the README.md. I'm not sure this is sufficient.

WDYT?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 16e0eec418..e910c314fd 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1223,6 +1223,37 @@  object library.")
 language and software synthesizer.")
     (license license:lgpl2.1+)))
 
+(define-public midicomp
+  ;; The latest tagged release is 9 years old and there have been
+  ;; unreleased fixes, so we take the last commit.
+  (let ((commit "70f76963cb0cdb3cbe03ec6e7246b1fb885d3c68")
+        (revision "1"))
+    (package
+      (name "midicomp")
+      (version (string-append "0.0.6-" revision "." (string-take commit 7)))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/markc/midicomp")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+           (base32
+            "12zh247c6v88ssy4l8v7yirh4bl2jcc1ch7f4gdry79a82kai1gf"))))
+     (build-system cmake-build-system)
+     (arguments
+      `(#:tests? #f))  ; no "check" target
+      (synopsis "MIDI compiler")
+      (description
+       "midicomp can manipulate SMF (Standard MIDI File) files.  It can both
+  read and write SMF files in 0 or format 1 and also read and write its own
+  plain text format.  This means a SMF file can be turned into easily
+  parseable text, edited with any text editor or filtered through any script
+  language, and recompiled back into a binary SMF file.")
+      (home-page "https://github.com/markc/midicomp")
+      (license license:agpl3))))
+
 (define-public clalsadrv
   (package
     (name "clalsadrv")