diff mbox series

[bug#46530] gnu: Add emacs-theme-sorcery.

Message ID MT_J3cj--7-2@tuta.io
State Accepted
Headers show
Series [bug#46530] gnu: Add emacs-theme-sorcery. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Adam Kandur Feb. 15, 2021, 10:50 a.m. UTC
From 39aeaead94df9e73db53f9ca1c7a4b373d55c6ad Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Mon, 15 Feb 2021 13:46:12 +0300
Subject: [PATCH] gnu: Add emacs-theme-sorcery.

* gnu/packages/emacs-xyz.scm (emacs-theme-sorcery): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou Feb. 15, 2021, 12:51 p.m. UTC | #1
Hello,

Adam Kandur via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-theme-sorcery): New variable.

Thank you. I applied the patch with the changes below.

> +(define-public emacs-theme-sorcery
> +  (let ((revision "0")
  ^^^
Your indentation uses nbsp instead of spaces.

> +        (commit "5a1c4445b9e6e09589a299a9962a6973272a0c2f"))

[...]

> +           (commit "master")))

I used (commit commit) since "master" is not stable, by essence.

> +      (synopsis "Sorcery is a dark and low-contrast Emacs theme inspired by apprentice and sourcerer.")

I shortened the synopsis.

> +      (license license:gpl3))))

I changed the license to gpl3+ since "sorcery-theme.el" file specifies
"or (at your option) any later version." for its license.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a757703..f6ee43d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -804,6 +804,29 @@  theme and apply them to the rest of Linux with Pywal.  Pywal only applies your
 theme to the current session.")
       (license license:gpl3+))))
 
+(define-public emacs-theme-sorcery
+  (let ((revision "0")
+        (commit "5a1c4445b9e6e09589a299a9962a6973272a0c2f"))
+    (package
+      (name "emacs-theme-sorcery")
+      (version "1.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+           (url "https://github.com/mtreca/emacs-theme-sorcery")
+           (commit "master")))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1b858049n6nw4qf60fmszjrhl80x7ssh32f7glj722kwy7404kdh"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-autothemer" ,emacs-autothemer)))
+       (home-page "https://github.com/mtreca/emacs-theme-sorcery")
+      (synopsis "Sorcery is a dark and low-contrast Emacs theme inspired by apprentice and sourcerer.")
+      (description "Sorcery is a dark and low-contrast Emacs theme inspired by apprentice and sourcerer.")
+      (license license:gpl3))))
+
 (define-public emacs-treepy
   (package
     (name "emacs-treepy")