diff mbox series

[bug#46443] gnu: cheese: Add gst-plugins-good as an input.

Message ID 20210211201208.23351-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#46443] gnu: cheese: Add gst-plugins-good as an input. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Christopher Baines Feb. 11, 2021, 8:12 p.m. UTC
This fixes an issue with choppy video recording. It also makes these lines not
appear in the build log:

meson.build:154: WARNING: vp8enc was not found. It needs to be installed before Cheese is run
meson.build:154: WARNING: webmmux was not found. It needs to be installed
before Cheese is run

* gnu/packages/gnome.scm (cheese)[inputs]: Add gst-plugins-good.
---
 gnu/packages/gnome.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Leo Famulari Feb. 13, 2021, 12:14 a.m. UTC | #1
On Thu, Feb 11, 2021 at 08:12:08PM +0000, Christopher Baines wrote:
> This fixes an issue with choppy video recording. It also makes these lines not
> appear in the build log:
> 
> meson.build:154: WARNING: vp8enc was not found. It needs to be installed before Cheese is run
> meson.build:154: WARNING: webmmux was not found. It needs to be installed
> before Cheese is run
> 
> * gnu/packages/gnome.scm (cheese)[inputs]: Add gst-plugins-good.

Thanks, please push!
Christopher Baines Feb. 13, 2021, 9:18 a.m. UTC | #2
Leo Famulari <leo@famulari.name> writes:

> On Thu, Feb 11, 2021 at 08:12:08PM +0000, Christopher Baines wrote:
>> This fixes an issue with choppy video recording. It also makes these lines not
>> appear in the build log:
>> 
>> meson.build:154: WARNING: vp8enc was not found. It needs to be installed before Cheese is run
>> meson.build:154: WARNING: webmmux was not found. It needs to be installed
>> before Cheese is run
>> 
>> * gnu/packages/gnome.scm (cheese)[inputs]: Add gst-plugins-good.
>
> Thanks, please push!

Thanks for taking a look, I've pushed to master as
2ebd74c33c13d604a5e423520a648728b8d49f9f.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c5c6b4dd8f..f7838f85a5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10400,6 +10400,7 @@  photo-booth-like software, such as Cheese.")
      `(("gnome-desktop" ,gnome-desktop)
        ("gobject-introspection" ,gobject-introspection)
        ("gst-plugins-base" ,gst-plugins-base)
+       ("gst-plugins-good" ,gst-plugins-good)
        ("gst-plugins-bad" ,gst-plugins-bad)
        ("gtk+" ,gtk+)
        ("libx11" ,libx11)