diff mbox series

[bug#46313] gnu: Add chiaki.

Message ID 20210205031731.27620-1-lle-bout@zaclys.net
State New
Headers show
Series [bug#46313] gnu: Add chiaki. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Léo Le Bouter Feb. 5, 2021, 3:17 a.m. UTC
* gnu/packages/games.scm (chiaki): New variable.
---
 gnu/packages/games.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Nicolas Goaziou Feb. 7, 2021, 9:43 a.m. UTC | #1
Hello,

Léo Le Bouter via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/games.scm (chiaki): New variable.

Thank you. Some comments follow.

> +             (recursive? #t)))

Do you know what sub-modules are being pulled? Could we unbundle them
instead?

> +    (synopsis "Free and Open Source PlayStation Remote Play Client")

Please remove "Free" and "Open Source": everything is in Guix. Also,
synopsis should not use titlecase:

    "PlayStation Remote Play client"

> +    (description "Chiaki is a Free and Open Source Software Client for
> +PlayStation 4 and PlayStation 5 Remote Play.")

See above. Also, couldyou expound a bit the description?

> +    (license
> +     (license:fsdg-compatible

It should be fsf-free instead of fsdg-compatible.

> +      "file://LICENSES/AGPL-3.0-only-OpenSSL.txt"
> +      "AGPL-3.0-only-OpenSSL"))))

I think the correct string would be "AGPL-3.0 WITH OpenSSL exception"
but I wonder if Guix cares about the exception.

Could you send an updated patch?


Regards,
Léo Le Bouter Feb. 7, 2021, 4:57 p.m. UTC | #2
On Sun, 2021-02-07 at 10:43 +0100, Nicolas Goaziou wrote:
> Hello,

Hello!

> 
> Léo Le Bouter via Guix-patches via <guix-patches@gnu.org> writes:
> 
> > * gnu/packages/games.scm (chiaki): New variable.
> 
> Thank you. Some comments follow.
> 
> > +             (recursive? #t)))
> 
> Do you know what sub-modules are being pulled? Could we unbundle them
> instead?

There is gf-complete, jerasure and nanopb. Will have to look for
unbundling.

> 
> > +    (synopsis "Free and Open Source PlayStation Remote Play
> > Client")
> 
> Please remove "Free" and "Open Source": everything is in Guix. Also,
> synopsis should not use titlecase:
> 
>     "PlayStation Remote Play client"
> 
> > +    (description "Chiaki is a Free and Open Source Software Client
> > for
> > +PlayStation 4 and PlayStation 5 Remote Play.")
> 
> See above. Also, couldyou expound a bit the description?
> 

Okay, merely copied the synopsis and description from the original
project.

> > +    (license
> > +     (license:fsdg-compatible
> 
> It should be fsf-free instead of fsdg-compatible.
> 
> > +      "file://LICENSES/AGPL-3.0-only-OpenSSL.txt"
> > +      "AGPL-3.0-only-OpenSSL"))))
> 

The thing is, the FSF does not approve that particular variant of the
license with OpenSSL exception so that's why I only specified it is
compatible.

> I think the correct string would be "AGPL-3.0 WITH OpenSSL exception"
> but I wonder if Guix cares about the exception.
> 
> Could you send an updated patch?
> 

ASAP.

> 
> Regards,

Thank you.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e3e18bf09e..3d6ba05a39 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12178,3 +12178,42 @@  game FPS.")
 implemented using ncurses user interface.  An SDL graphical version is also
 available.")
     (license license:gpl3+)))
+
+(define-public chiaki
+  (package
+    (name "chiaki")
+    (version "2.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~thestr4ng3r/chiaki")
+             (commit (string-append "v" version))
+             (recursive? #t)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1kjaahv80p040wicj1a4ac1j2zsg0dbbf60a9aapn45qlkq80h2n"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("python" ,python)
+       ("protobuf" ,protobuf)
+       ("pkg-config" ,pkg-config)
+       ("python-protobuf" ,python-protobuf)))
+    (inputs
+     `(("ffmpeg" ,ffmpeg)
+       ("opus" ,opus)
+       ("openssl" ,openssl)
+       ("libevdev" ,libevdev)
+       ("qtbase" ,qtbase)
+       ("qtmultimedia" ,qtmultimedia)
+       ("qtsvg" ,qtsvg)
+       ("sdl2" ,sdl2)))
+    (home-page "https://git.sr.ht/~thestr4ng3r/chiaki")
+    (synopsis "Free and Open Source PlayStation Remote Play Client")
+    (description "Chiaki is a Free and Open Source Software Client for
+PlayStation 4 and PlayStation 5 Remote Play.")
+    (license
+     (license:fsdg-compatible
+      "file://LICENSES/AGPL-3.0-only-OpenSSL.txt"
+      "AGPL-3.0-only-OpenSSL"))))