diff mbox series

[bug#45449] Adds python-serial

Message ID D9k4_yhftAnUjvFdpnx6gnsOEJ_4BkfPLA9Uj85O0Pk6RkJdNemV0xks0kFdtV0f-NhGHD3hlF9sJu1r56gtZP7H1M78phA1MU-fLZM7_vE=@protonmail.com
State New
Headers show
Series [bug#45449] Adds python-serial | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

rdes Dec. 26, 2020, 6:15 p.m. UTC
Hello,

The attached patch adds python-serial.

Sent with [ProtonMail](https://protonmail.com) Secure Email.

Comments

Mathieu Othacehe Jan. 6, 2021, 10 a.m. UTC | #1
Hello Ryan,

> * gnu/packages/python-xyz.scm (python-serial): New variable.

Thanks for this patch. Running 'guix lint' reports several issues. The
indentation also has to be fixed.

You can read:
https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html
for further information on how to write the synopsis and description
fields.

Thanks,

Mathieu
diff mbox series

Patch

From 94c4d73deec179e05d2e8ad26a9ebfacabaf5e47 Mon Sep 17 00:00:00 2001
From: Ryan Desfosses <rdes@protonmail.com>
Date: Sat, 26 Dec 2020 12:48:25 -0500
Subject: [PATCH] gnu: python-serial: New variable.

* gnu/packages/python-xyz.scm (python-serial): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index acde5a5e5e..0c42a46102 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -93,6 +93,7 @@ 
 ;;; Copyright © 2020 Diego N. Barbato <dnbarbato@posteo.de>
 ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
+;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23201,3 +23202,27 @@  backport of the @code{dataclasses} module for Python 3.6.")
     (description "@code{python-pywatchman} is a library to connect and
 query Watchman to discover file changes.")
     (license license:bsd-3)))
+
+(define-public python-serial
+  (package
+  (name "python-serial")
+  (version "0.0.97")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "serial" version))
+      (sha256
+        (base32
+          "0j7qjif5d9mxbdwcyyhr7fpcvjq7x16ar9n3mk95xgyx4yhm08al"))))
+  (build-system python-build-system)
+  (propagated-inputs
+    `(("python-future" ,python-future)
+      ("python-iso8601" ,python-iso8601)
+      ("python-pyyaml" ,python-pyyaml)))
+  (home-page
+    "https://bitbucket.com/davebelais/serial.git")
+  (synopsis
+    "A framework for serializing/deserializing JSON/YAML/XML into python class instances and vice versa")
+  (description
+    "A framework for serializing/deserializing JSON/YAML/XML into python class instances and vice versa")
+  (license license:expat)))
-- 
2.29.2