diff mbox series

[bug#40399] build-system/gnu: Allow overriding of bootstrap scripts.

Message ID 20200403051133.10138-1-rekado@elephly.net
State Accepted
Delegated to: Christopher Baines
Headers show
Series [bug#40399] build-system/gnu: Allow overriding of bootstrap scripts. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Ricardo Wurmus April 3, 2020, 5:11 a.m. UTC
* guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Accept
bootstrap-scripts keyword argument and pass it to gnu-build.
(%bootstrap-scripts): New variable.
* guix/build/gnu-build-system.scm (%bootstrap-scripts): Remove variable.
(bootstrap): Remove default value for bootstrap-scripts argument.
---
 guix/build-system/gnu.scm       | 8 ++++++++
 guix/build/gnu-build-system.scm | 6 +-----
 2 files changed, 9 insertions(+), 5 deletions(-)

Comments

Ricardo Wurmus April 4, 2020, 7:40 p.m. UTC | #1
Ricardo Wurmus <rekado@elephly.net> writes:

> * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Accept
> bootstrap-scripts keyword argument and pass it to gnu-build.
> (%bootstrap-scripts): New variable.
> * guix/build/gnu-build-system.scm (%bootstrap-scripts): Remove variable.
> (bootstrap): Remove default value for bootstrap-scripts argument.

This is for the next core-updates branch.
Christopher Baines Dec. 18, 2020, 11:19 a.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> writes:

> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Accept
>> bootstrap-scripts keyword argument and pass it to gnu-build.
>> (%bootstrap-scripts): New variable.
>> * guix/build/gnu-build-system.scm (%bootstrap-scripts): Remove variable.
>> (bootstrap): Remove default value for bootstrap-scripts argument.
>
> This is for the next core-updates branch.

This looks reasonable to me, I believe now is a good time to push to
core-updates as well.

Thanks,

Chris
Ricardo Wurmus Dec. 23, 2020, 12:36 p.m. UTC | #3
Christopher Baines <mail@cbaines.net> writes:

> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Ricardo Wurmus <rekado@elephly.net> writes:
>>
>>> * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Accept
>>> bootstrap-scripts keyword argument and pass it to gnu-build.
>>> (%bootstrap-scripts): New variable.
>>> * guix/build/gnu-build-system.scm (%bootstrap-scripts): Remove variable.
>>> (bootstrap): Remove default value for bootstrap-scripts argument.
>>
>> This is for the next core-updates branch.
>
> This looks reasonable to me, I believe now is a good time to push to
> core-updates as well.

Thanks for the review.

I pushed it to core-updates.
diff mbox series

Patch

diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index 7266fa0009..f28d59cc5e 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -322,10 +322,15 @@  standard packages used as implicit inputs of the GNU build system."
   ;; Regexp matching license files.
   "^(COPYING.*|LICEN[CS]E.*|[Ll]icen[cs]e.*|Copy[Rr]ight(\\.(txt|md))?)$")
 
+(define %bootstrap-scripts
+  ;; Typical names of Autotools "bootstrap" scripts.
+  '("bootstrap" "bootstrap.sh" "autogen.sh"))
+
 (define* (gnu-build store name input-drvs
                     #:key (guile #f)
                     (outputs '("out"))
                     (search-paths '())
+                    (bootstrap-scripts %bootstrap-scripts)
                     (configure-flags ''())
                     (make-flags ''())
                     (out-of-source? #f)
@@ -398,6 +403,7 @@  packages that must not be referenced."
                                         search-paths)
                   #:phases ,phases
                   #:locale ,locale
+                  #:bootstrap-scripts ,bootstrap-scripts
                   #:configure-flags ,configure-flags
                   #:make-flags ,make-flags
                   #:out-of-source? ,out-of-source?
@@ -476,6 +482,7 @@  is one of `host' or `target'."
                           (search-paths '())
                           (native-search-paths '())
 
+                          (bootstrap-scripts %bootstrap-scripts)
                           (configure-flags ''())
                           (make-flags ''())
                           (out-of-source? #f)
@@ -557,6 +564,7 @@  platform."
                                              native-search-paths)
                     #:phases ,phases
                     #:locale ,locale
+                    #:bootstrap-scripts ,bootstrap-scripts
                     #:configure-flags ,configure-flags
                     #:make-flags ,make-flags
                     #:out-of-source? ,out-of-source?
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index 4df0bb4904..72a188955d 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -163,11 +163,7 @@  working directory."
         (chdir (first-subdirectory "."))))
   #t)
 
-(define %bootstrap-scripts
-  ;; Typical names of Autotools "bootstrap" scripts.
-  '("bootstrap" "bootstrap.sh" "autogen.sh"))
-
-(define* (bootstrap #:key (bootstrap-scripts %bootstrap-scripts)
+(define* (bootstrap #:key bootstrap-scripts
                     #:allow-other-keys)
   "If the code uses Autotools and \"configure\" is missing, run
 \"autoreconf\".  Otherwise do nothing."