diff mbox series

[bug#44274] gnu: Add emacs-powershell.el

Message ID MKisHT9--3-2@tuta.io
State Accepted
Headers show
Series [bug#44274] gnu: Add emacs-powershell.el | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Adam Kandur Oct. 28, 2020, 11:04 a.m. UTC
hi, attached new patch. hope it is correct



Oct 28, 2020, 10:01 by mail@nicolasgoaziou.fr:

> Adam Kandur via Guix-patches via <guix-patches@gnu.org> writes:
>
>> +      (arguments
>> +       `(#:include '("\\.el$")))
>>
>
> In addition to my other comments, I don't think the section above is
> needed.
>
> Regards,
>

Comments

Nicolas Goaziou Oct. 29, 2020, 9:20 a.m. UTC | #1
Hello,

Adam Kandur <rndd@tuta.io> writes:

> hi, attached new patch. hope it is correct

I fixed indentation, the version tag, added a home-page, tweaked the
description, and pushed your patch.

Thanks.

Regards,
diff mbox series

Patch

From 288fbe826b26d088c70c876ef74afd5445b63609 Mon Sep 17 00:00:00 2001
From: Adam <rndd@tuta.io>
Date: Wed, 28 Oct 2020 14:02:26 +0300
Subject: [PATCH] gnu: Add emacs-powershell.

* gnu/packages/emacs-xyz.scm (emacs-powershell): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 40e4c63..6684678 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13232,6 +13232,28 @@  literate programming tools for exporting, weaving and tangling.")
        "Edit YAML files for Ansible containing embedded Jinja2 templating.")
       (license license:gpl3+))))
 
+(define-public emacs-powershell
+  (let ((revision "0")
+        (commit "d1b3f95669343399f199f291ef76c09a0ede5e60"))
+    ;; tagged branch 0.1 is outdated (2015)
+    (package
+      (name "emacs-powershell")
+      (build-system emacs-build-system)
+      (version "0.3")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+	       (url "https://github.com/jschaf/powershell.el")
+	       (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1cxhzaaig88zhylyycvb3849r85j1ijqklnh9zbqsfl2zhpb0g5c"))))
+      (home-page "")
+      (synopsis "Emacs mode for editing PowerShell scripts")
+      (description "@code{powershell.el} Mode is an Emacs major mode for editing and running Microsoft PowerShell files.")
+    (license license:gpl3+))))
+
 (define-public emacs-polymode-org
   (package
     (name "emacs-polymode-org")
-- 
2.28.0