diff mbox series

[bug#43929] gnu: Add pijul.

Message ID 87lfgcog2g.fsf@asu.edu
State New
Headers show
Series [bug#43929] gnu: Add pijul. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

John Soo Oct. 11, 2020, 4:58 p.m. UTC
Hi Guix,

I've had these patches for a while and debated whether they should be
merged. Pijul works but 2.0 is reportedly being worked on. I haven't
seen much news on version 2 so I think 1.0 should be made available to
try.

Kindly,

John

Comments

Julien Lepiller Oct. 11, 2020, 5:40 p.m. UTC | #1
Oh that is great! I've been wanting to try pijul out since more than a year but never found the time to package it. Thanks!

I'm not sure I know rust enough to review this, and I'm a bit busy. If nobody else has started a review by next saturday, please ping me again!

Le 11 octobre 2020 12:58:15 GMT-04:00, John Soo <jsoo1@asu.edu> a écrit :
>Hi Guix,
>
>I've had these patches for a while and debated whether they should be
>merged. Pijul works but 2.0 is reportedly being worked on. I haven't
>seen much news on version 2 so I think 1.0 should be made available to
>try.
>
>Kindly,
>
>John
Ludovic Courtès Oct. 28, 2020, 2:57 p.m. UTC | #2
Hi Julien,

Julien Lepiller <julien@lepiller.eu> skribis:

> Oh that is great! I've been wanting to try pijul out since more than a
> year but never found the time to package it. Thanks!
>
> I'm not sure I know rust enough to review this, and I'm a bit busy. If
> nobody else has started a review by next saturday, please ping me
> again!

Are you taking a look?  If not, let’s call for help from the Rust-savvy
people among us.  :-)

Thanks,
Ludo’.
John Soo Oct. 28, 2020, 3:13 p.m. UTC | #3
Hey everyone, 

 
Quick update.
 

 
I have been busy rebasing these patches.    I may have a new set this week.
 

 
Also pijul 2 is coming very soon. Should I wait to submit that instead?
 

 
- John
Simon Tournier Oct. 28, 2020, 3:42 p.m. UTC | #4
Hi,

On Wed, 28 Oct 2020 at 08:13, John Soo <jsoo1@asu.edu> wrote:
  
> I have been busy rebasing these patches.  I may have a new set this
> week

It could be cool if it could be included in the v1.2. :-)


> Also pijul 2 is coming very soon. Should I wait to submit that
> instead? 

From my point of view, because of the “time-machine”, it is nice to
include any version – especially when it is already done. :-)


Cheers,
simon
Julien Lepiller Oct. 28, 2020, 5:37 p.m. UTC | #5
Le 28 octobre 2020 11:42:07 GMT-04:00, zimoun <zimon.toutoune@gmail.com> a écrit :
>Hi,
>
>On Wed, 28 Oct 2020 at 08:13, John Soo <jsoo1@asu.edu> wrote:
>  
>> I have been busy rebasing these patches.  I may have a new set this
>> week
>
>It could be cool if it could be included in the v1.2. :-)
>
>
>> Also pijul 2 is coming very soon. Should I wait to submit that
>> instead? 
>
>From my point of view, because of the “time-machine”, it is nice to
>include any version – especially when it is already done. :-)

Yeah I agree, you don't have to wait, since you already have everything available :)

Sorry I didn't do a review, I ended up being busy with work and other things.

>
>
>Cheers,
>simon
diff mbox series

Patch

From cd2e19016bc0f7ce1979bb2e1ae4fc72e46682e7 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Wed, 17 Jun 2020 18:23:46 -0700
Subject: [PATCH 57/57] gnu: Add pijul.

* gnu/packages/rust-apps.scm (pijul): New variable.
---
 gnu/packages/rust-apps.scm | 113 +++++++++++++++++++++++++++++++++++++
 1 file changed, 113 insertions(+)

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index f5501d67dd..3448ecb877 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -30,8 +30,11 @@ 
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crates-io)
   #:use-module (gnu packages crates-graphics)
+  #:use-module (gnu packages crypto)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages jemalloc)
+  #:use-module (gnu packages llvm)
+  #:use-module (gnu packages nettle)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -238,6 +241,116 @@  for distinguishing different kinds of bytes such as NULL bytes, printable ASCII
 characters, ASCII whitespace characters, other ASCII characters and non-ASCII.")
     (license (list license:expat license:asl2.0))))
 
+(define-public pijul
+  (package
+    (name "pijul")
+    (version "0.12.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pijul" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "12aqpfd2si70qbvfnn9kvznxyd5g5gsb1kk1q52wm077cd03yapr"))))
+    (build-system cargo-build-system)
+    (inputs
+     `(("clang" ,clang)
+       ("libressl" ,libressl)
+       ("libsodium" ,libsodium)
+       ("nettle" ,nettle)
+       ("pkg-config" ,pkg-config)))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-atty" ,rust-atty-0.2)
+        ("rust-base64" ,rust-base64-0.10)
+        ("rust-bincode" ,rust-bincode-1)
+        ("rust-bs58" ,rust-bs58-0.2)
+        ("rust-chrono" ,rust-chrono-0.4)
+        ("rust-clap" ,rust-clap-2)
+        ("rust-cryptovec" ,rust-cryptovec-0.4)
+        ("rust-dirs" ,rust-dirs-1.0)
+        ("rust-env-logger" ,rust-env-logger-0.6)
+        ("rust-failure" ,rust-failure-0.1)
+        ("rust-flate2" ,rust-flate2-1.0)
+        ("rust-futures" ,rust-futures-0.1)
+        ("rust-getch" ,rust-getch-0.2)
+        ("rust-hex" ,rust-hex-0.3)
+        ("rust-ignore" ,rust-ignore-0.4)
+        ("rust-libpijul" ,rust-libpijul-0.12)
+        ("rust-line" ,rust-line-0.1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-pathdiff" ,rust-pathdiff-0.1)
+        ("rust-progrs" ,rust-progrs-0.1)
+        ("rust-rand" ,rust-rand-0.6)
+        ("rust-regex" ,rust-regex-1)
+        ("rust-reqwest" ,rust-reqwest-0.9)
+        ("rust-rpassword" ,rust-rpassword-2.1.0)
+        ("rust-sequoia-openpgp" ,rust-sequoia-openpgp-0.9)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-derive" ,rust-serde-derive-1)
+        ("rust-shell-escape" ,rust-shell-escape-0.1)
+        ("rust-tar" ,rust-tar-0.4)
+        ("rust-tempfile" ,rust-tempfile-3)
+        ("rust-term" ,rust-term-0.5)
+        ("rust-thrussh" ,rust-thrussh-0.21)
+        ("rust-thrussh-config" ,rust-thrussh-config-0.2)
+        ("rust-thrussh-keys" ,rust-thrussh-keys-0.11)
+        ("rust-tokio" ,rust-tokio-0.1)
+        ("rust-tokio-uds" ,rust-tokio-uds-0.2)
+        ("rust-toml" ,rust-toml-0.4)
+        ("rust-username" ,rust-username-0.2))
+       #:cargo-development-inputs
+       (("rust-walkdir" ,rust-walkdir-2))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'set-clang-env
+           (lambda* (#:key inputs #:allow-other-keys)
+             (setenv
+              "LIBCLANG_PATH"
+              (string-append (assoc-ref inputs "clang") "/lib"))
+             #t))
+         (add-after 'install 'install-completions
+           (lambda* (#:key outputs #:allow-other-keys)
+             (use-modules (ice-9 popen)
+                          (ice-9 textual-ports))
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin"))
+                    (share (string-append out "/share"))
+                    (bash (string-append
+                           share "/bash-completion/completions"))
+                    (zsh (string-append
+                          share "/zsh/site-functions"))
+                    (fish (string-append
+                           share "/fish/vendor_completions.d")))
+               (for-each
+                (lambda (x)
+                  (let ((dir (cddr x))
+                        (file (cadr x))
+                        (shell (car x)))
+                    (mkdir-p dir)
+                    (call-with-output-file (string-append dir "/" file)
+                      (lambda (f)
+                        (let* ((cmd (string-append
+                                     bin "/pijul generate-completions --"
+                                     shell))
+                               (pipe (open-input-pipe cmd))
+                               (completion (get-string-all pipe)))
+                          (format f "~A" completion)
+                          (close-pipe pipe)))) ))
+                `(("bash" . ("pijul" . ,bash))
+                  ("zsh" . ("_pijul" . ,zsh))
+                  ("fish" . ("pijul.fish" . ,fish))))
+               #t))))))
+    (home-page "https://pijul.org/")
+    (synopsis
+     "Patch-based distributed version control system")
+    (description
+     "This package provides a patch-based distributed version control
+system, easy to use and fast.  Command-line interface.")
+    (license license:gpl2+)))
+
 (define-public racer
   (package
     (name "racer")
-- 
2.28.0