diff mbox series

[bug#44222] emacs-lojban and emacs-lojban-mode packages

Message ID 87h7qi9eu0.fsf@dustycloud.org
State New
Headers show
Series [bug#44222] emacs-lojban and emacs-lojban-mode packages | expand

Checks

Context Check Description
cbaines/submitting builds fail
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber Oct. 25, 2020, 9:27 p.m. UTC
Well, here are some WIP patches... two of them.  Sadly they don't work
as-is, I'm hitting an error:

starting phase `build'
Checking /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/...
Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban-autoloads.el...
Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el...
Symbol’s value as variable is void: lojban-c-rgx
command "/gnu/store/k826y34z8zzjj57jv2nldmpw6vsdd145-emacs-minimal-27.1/bin/emacs" "--quick" "--batch" "--eval=(eval '(progn (setq byte-compile-debug t) (byte-recompile-directory (file-name-as-directory \"/gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp\") 0 1)) t)" failed with status 255
builder for `/gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv' failed with exit code 1
build of /gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv failed

But if I look at the downloaded lojban.el file, I see it there:

$ grep lojban-c-rgx /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el 
(defconst lojban-c-rgx (concat "[" lojban-c-letter-set "]")
...

Any ideas what might be causing it?

Comments

Nicolas Goaziou Oct. 27, 2020, 9:29 p.m. UTC | #1
Hello,

Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

> Well, here are some WIP patches... two of them.  Sadly they don't work
> as-is, I'm hitting an error:
>
> starting phase `build'
> Checking /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/...
> Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban-autoloads.el...
> Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el...
> Symbol’s value as variable is void: lojban-c-rgx
> command
> "/gnu/store/k826y34z8zzjj57jv2nldmpw6vsdd145-emacs-minimal-27.1/bin/emacs"
> "--quick" "--batch" "--eval=(eval '(progn (setq byte-compile-debug t)
> (byte-recompile-directory (file-name-as-directory
> \"/gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp\")
> 0 1)) t)" failed with status 255
> builder for `/gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv' failed with exit code 1
> build of /gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv failed
>
> But if I look at the downloaded lojban.el file, I see it there:
>
> $ grep lojban-c-rgx /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el 
> (defconst lojban-c-rgx (concat "[" lojban-c-letter-set "]")
> ...
>
> Any ideas what might be causing it?

This:

      (eval-when-compile
	(concat "\\(" lojban-c-rgx "\\)\\1"))

is the culprit. This is evaluated before compiling the file, when the
defconst is not defined yet. 

Considering `lojban-c-rgx' is a constant, I'm not sure why
`eval-when-compile' would be better than defining the result as a new
constant.

In any case, a poor man's fix could be replacing `eval-when-compile'
with `progn', or

    (concat "\\(" lojban-c-rgx "\\)\\1")

with

    "\\([bcdfgj-npr-tvxz]\\)\\1"

Also,

+    (synopsis "Emacs utilities for operating on lojban text")
+    (description
+     "lojban.el is an emacs library of functions, variables, regexps and
+interactive commands for handling lojban text.")

I would capitalize Emacs, and Lojban.

Regards,
Christine Lemmer-Webber Oct. 28, 2020, 3:53 a.m. UTC | #2
Nicolas Goaziou writes:

> Hello,
>
> Christopher Lemmer Webber <cwebber@dustycloud.org> writes:
>
>> Well, here are some WIP patches... two of them.  Sadly they don't work
>> as-is, I'm hitting an error:
>>
>> starting phase `build'
>> Checking /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/...
>> Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban-autoloads.el...
>> Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el...
>> Symbol’s value as variable is void: lojban-c-rgx
>> command
>> "/gnu/store/k826y34z8zzjj57jv2nldmpw6vsdd145-emacs-minimal-27.1/bin/emacs"
>> "--quick" "--batch" "--eval=(eval '(progn (setq byte-compile-debug t)
>> (byte-recompile-directory (file-name-as-directory
>> \"/gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp\")
>> 0 1)) t)" failed with status 255
>> builder for `/gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv' failed with exit code 1
>> build of /gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv failed
>>
>> But if I look at the downloaded lojban.el file, I see it there:
>>
>> $ grep lojban-c-rgx /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el 
>> (defconst lojban-c-rgx (concat "[" lojban-c-letter-set "]")
>> ...
>>
>> Any ideas what might be causing it?
>
> This:
>
>       (eval-when-compile
> 	(concat "\\(" lojban-c-rgx "\\)\\1"))
>
> is the culprit. This is evaluated before compiling the file, when the
> defconst is not defined yet. 

I see!

> Considering `lojban-c-rgx' is a constant, I'm not sure why
> `eval-when-compile' would be better than defining the result as a new
> constant.
>
> In any case, a poor man's fix could be replacing `eval-when-compile'
> with `progn', or
>
>     (concat "\\(" lojban-c-rgx "\\)\\1")
>
> with
>
>     "\\([bcdfgj-npr-tvxz]\\)\\1"

I'll give that a try.

> Also,
>
> +    (synopsis "Emacs utilities for operating on lojban text")
> +    (description
> +     "lojban.el is an emacs library of functions, variables, regexps and
> +interactive commands for handling lojban text.")
>
> I would capitalize Emacs, and Lojban.

Sounds sensible!

I'll try to follow up on this patch sometime in the next week (but no
promises).

> Regards,
Nicolas Goaziou April 26, 2023, 12:51 p.m. UTC | #3
Hello,

Someone created a repository holding both files, so I took the liberty
to change upstream location in your package, and applied the patch.

Thanks,
diff mbox series

Patch

From 4eabeccaf2aaf879e3cc829899c143aaf55d082b Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Sun, 25 Oct 2020 17:21:56 -0400
Subject: [PATCH] gnu: Add emacs-lojban-mode.

* gnu/packages/emacs-xyz.scm (emacs-lojban-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ce5b8ac4ca..107bd6a9bf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25178,3 +25178,25 @@  service.")
      "lojban.el is an emacs library of functions, variables, regexps and
 interactive commands for handling lojban text.")
     (license license:gpl2+)))
+
+(define-public emacs-lojban-mode
+  (package
+    (name "emacs-lojban-mode")
+    (version "0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri "https://www.emacswiki.org/emacs/download/lojban-mode.el")
+       (sha256 (base32 "1l8wq3hzr77k5ibqb2ghzjskfvjhgfvwan1v8gma4msi5mjfiv30"))))
+    (build-system emacs-build-system)
+    (home-page "https://www.emacswiki.org/emacs/lojban-mode.el")
+    (synopsis "Emacs minor mode for lojban text")
+    (propagated-inputs
+     `(("emacs-lojban" ,emacs-lojban)))
+    (description
+     "lojban-mode provides a specialized minor mode for lojban text.
+It includes syntactical highlighting for lojban words.
+The three basic word types (cmavo, cmene, and brivla), sentence
+separators and attitudinal indicators are highlighted with
+different faces.")
+    (license license:gpl2+)))
-- 
2.28.0