diff mbox series

[bug#43825] bioinformatics: htslib: Enable support for custom URI schemes.

Message ID be76ac8e2264d9be1d6c56dc4f08dcd013c87054.camel@gnu.org
State Accepted
Headers show
Series [bug#43825] bioinformatics: htslib: Enable support for custom URI schemes. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Roel Janssen Oct. 6, 2020, 8:48 a.m. UTC
Dear Guix,

I'd like to apply this patch to enable accessing files stored in
certain "cloud" systems.  I added "--enable-libcurl" although it is not
strictly necessary. Both "--enable-gcs" and "--enable-s3" require
libcurl to be enabled, so this just seems reassuringly clear to me. 

Kind regards,
Roel Janssen

Comments

Efraim Flashner Oct. 6, 2020, 7:23 p.m. UTC | #1
On Tue, Oct 06, 2020 at 10:48:31AM +0200, Roel Janssen wrote:
> Dear Guix,
> 
> I'd like to apply this patch to enable accessing files stored in
> certain "cloud" systems.  I added "--enable-libcurl" although it is not
> strictly necessary. Both "--enable-gcs" and "--enable-s3" require
> libcurl to be enabled, so this just seems reassuringly clear to me. 
> 
> Kind regards,
> Roel Janssen
> 

That sounds fine to me.
Ricardo Wurmus Oct. 6, 2020, 8:56 p.m. UTC | #2
Hi Roel,

> I'd like to apply this patch to enable accessing files stored in
> certain "cloud" systems.

Sounds good to me.  Please move the explanation from the commit message
to the code as a comment.

As commit message please use:

* gnu/packages/bioinformatics.scm (htslib)[arguments]: Enable support for custom URIs.
Roel Janssen Oct. 7, 2020, 1:37 p.m. UTC | #3
On Tue, 2020-10-06 at 22:56 +0200, Ricardo Wurmus wrote:
> Hi Roel,
> 
> > I'd like to apply this patch to enable accessing files stored in
> > certain "cloud" systems.
> 
> Sounds good to me.  Please move the explanation from the commit
> message
> to the code as a comment.
> 
> As commit message please use:
> 
> * gnu/packages/bioinformatics.scm (htslib)[arguments]: Enable support
> for custom URIs.
> 

Thank you! I've committed this patch at fb0037a.

Kind regards,
Roel Janssen
diff mbox series

Patch

From fbec05df4bcc630ac51f59cd27f8e45a6ac41002 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Tue, 6 Oct 2020 10:41:56 +0200
Subject: [PATCH] bioinformatics: htslib: Enable support for custom URI
 schemes.

This commit enables the translation of "gs://" and "s3://"
URIs into their equivalent HTTPS variants.

* gnu/packages/bioinformatics.scm (htslib): Enable support for custom URIs.
---
 gnu/packages/bioinformatics.scm | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fda7255662..c8bf7cfdad 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4225,6 +4225,10 @@  performance.")
                (base32
                 "16ljv43sc3fxmv63w7b2ff8m1s7h89xhazwmbm1bicz8axq8fjz0"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags '("--enable-gcs"
+                           "--enable-libcurl"
+                           "--enable-s3")))
     (inputs
      `(("curl" ,curl)
        ("openssl" ,openssl)))
-- 
2.26.2