diff mbox series

[bug#43185] gnu: emacs-auctex: Configure executable paths.

Message ID 20200903173655.14176-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#43185] gnu: emacs-auctex: Configure executable paths. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Arun Isaac Sept. 3, 2020, 5:36 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-auctex): Configure absolute paths to
ghostscript and texlive executables.
[inputs]: Add ghostscript.
---
 gnu/packages/emacs-xyz.scm | 19 ++++++++++++++++++-
 1 file changed, 18 insertions(+), 1 deletion(-)

Comments

Mathieu Othacehe Sept. 4, 2020, 9:57 a.m. UTC | #1
Hello Arun,

> * gnu/packages/emacs-xyz.scm (emacs-auctex): Configure absolute paths to
> ghostscript and texlive executables.
> [inputs]: Add ghostscript.

This looks fine to me.

Thanks,

Mathieu
Arun Isaac Sept. 4, 2020, 11:01 a.m. UTC | #2
Pushed to master, thanks for the review!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3482686ccd..e5d748b611 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -175,6 +175,7 @@ 
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages shells)
   #:use-module (gnu packages sqlite)
+  #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages video)
   #:use-module (gnu packages haskell-xyz)
@@ -1914,6 +1915,21 @@  as a library for other Emacs packages.")
        #:exclude '("^tests/" "^latex/README")
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'configure
+           (lambda* (#:key inputs #:allow-other-keys)
+             (emacs-substitute-variables "preview.el"
+               ("preview-gs-command"
+                (string-append (assoc-ref inputs "ghostscript") "/bin/gs")))
+             (substitute* "preview.el"
+               (("\"dvipng ")
+                (string-append "\"" (assoc-ref inputs "texlive")
+                               "/bin/dvipng "))
+               (("\"dvips ")
+                (string-append "\"" (assoc-ref inputs "texlive")
+                               "/bin/dvips "))
+               (("\"pdf2dsc ")
+                (string-append "\"" (assoc-ref inputs "ghostscript")
+                               "/bin/pdf2dsc ")))))
          (add-after 'install 'install-doc
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -1928,7 +1944,8 @@  as a library for other Emacs packages.")
     (native-inputs
      `(("perl" ,perl)))
     (inputs
-     `(("texlive" ,(texlive-union (list texlive-amsfonts)))))
+     `(("ghostscript" ,ghostscript)
+       ("texlive" ,(texlive-union (list texlive-amsfonts)))))
     (home-page "https://www.gnu.org/software/auctex/")
     (synopsis "Integrated environment for TeX")
     (description