diff mbox series

[bug#42638] bump libuv to 1.38

Message ID goNKsRaoBFRnv5vE8NIattm6PQSs6robVx9Am6DZQVxrL4l2NXBZLDDzgl0T7hYI7-iqd85HOC4HhIl3nMcyK4UtJCNOKAuXyB7tfVSN00E=@protonmail.com
State New
Headers show
Series [bug#42638] bump libuv to 1.38 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

vasilii.smirnov--- via Guix-patches" via July 31, 2020, 5:08 p.m. UTC
Empty Message

Comments

Mathieu Othacehe Aug. 1, 2020, 6:59 a.m. UTC | #1
Hello Formbi,

When updating a package, the commit message has to follow a few
conventions detailed in the manual here:
https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html.

> +(define-public libuv-1.38
> +  (package
> +    (inherit libuv)
> +    (version "1.38.1")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://dist.libuv.org/dist/v" version
> +                                  "/libuv-v" version ".tar.gz"))
> +              (sha256
> +               (base32
> +                "0iy6yp9nrxpj643w7la3kl3j59ni59b0l4v6n23a63s8kqkpvkhf"))))))

Regarding this very update, why do we need this specific version?

Thanks,

Mathieu
vasilii.smirnov--- via Guix-patches" via Aug. 1, 2020, 9:47 p.m. UTC | #2
>why do we need this specific version?

It's needed by the 14.6 version of Node.
Maja Kądziołka Aug. 6, 2020, 9:28 p.m. UTC | #3
On Sat, Aug 01, 2020 at 09:47:59PM +0000, Formbi wrote:
> >why do we need this specific version?
> 
> It's needed by the 14.6 version of Node.

The core-updates branch already has libuv 1.38.1, so this patch might
become unnecessary depending on when Node 14.6 gets added - I think it
would be better if you submitted this patch as part of the Node 14.6
patchstack.

Regards,
Jakub Kądziołka
Maja Kądziołka Aug. 6, 2020, 9:31 p.m. UTC | #4
On Thu, Aug 06, 2020 at 11:28:55PM +0200, Jakub Kądziołka wrote:
> On Sat, Aug 01, 2020 at 09:47:59PM +0000, Formbi wrote:
> > >why do we need this specific version?
> > 
> > It's needed by the 14.6 version of Node.
> 
> The core-updates branch already has libuv 1.38.1, so this patch might
> become unnecessary depending on when Node 14.6 gets added - I think it
> would be better if you submitted this patch as part of the Node 14.6
> patchstack.
> 
> Regards,
> Jakub Kądziołka

Whoops, I didn't see your Node patch, as the page-break on Debbugs
obscured it. Not too long ago we only had a single page worth of pending
patches... :/
Jelle Licht May 28, 2023, 9:56 p.m. UTC | #5
We now use libuv@1.44.2 on master (/w node@18), so closing this one.
diff mbox series

Patch

From 58ed4908680d98a1b4769b40a47ded3fd49cfc6b Mon Sep 17 00:00:00 2001
From: Formbi <formbi@protonmail.com>
Date: Fri, 31 Jul 2020 18:59:55 +0200
Subject: [PATCH] bump libuv

---
 gnu/packages/libevent.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)

diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index dab574a155..3e7189dd56 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -133,6 +133,18 @@  resolution, asynchronous file system operations, and threading primitives.")
     ;; details.  Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
     (license (list expat cc-by4.0))))
 
+(define-public libuv-1.38
+  (package
+    (inherit libuv)
+    (version "1.38.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://dist.libuv.org/dist/v" version
+                                  "/libuv-v" version ".tar.gz"))
+              (sha256
+               (base32
+                "0iy6yp9nrxpj643w7la3kl3j59ni59b0l4v6n23a63s8kqkpvkhf"))))))
+
 (define-public perl-anyevent
   (package
     (name "perl-anyevent")
-- 
2.26.0