diff mbox series

[bug#40537] gnu: Add bchoppr.

Message ID a51e992c201a13e3f8f3bf43bf0f935c63e7b27a.camel@zrythm.org
State Accepted
Delegated to: Christopher Baines
Headers show
Series [bug#40537] gnu: Add bchoppr. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou April 10, 2020, 12:38 p.m. UTC
Hi,

These patches add 3 new LV2 plugins by the same author as bsequencer:
bchoppr
bshapr
bjumblr

Thanks,
Alex

Comments

Christopher Baines April 14, 2020, 7:06 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> These patches add 3 new LV2 plugins by the same author as bsequencer:
> bchoppr
> bshapr
> bjumblr

I've got a couple of comments. It looks to me like it would be clearer
to not have the packages inherit from bsequencer. Some copying in the
package definitions is fine if there are similarities between packages.

The second thing is that I'd try to avoid adding package definitions at
the end of files, just because it can lead to more merge conflicts.

Would you be able to send some updated patches?

Thanks,

Chris
Alexandros Theodotou April 28, 2020, 3:11 p.m. UTC | #2
Hi Chris,

I think these should inherit from bsequencer since these are plugins by
the same author and it's reasonable that they follow the same build
procedure. We already to do this for other similar situations and it
also makes maintenance easier and DRY. Perhaps moving them below
bsequencer would be a better solution?

> The second thing is that I'd try to avoid adding package definitions
> at
> the end of files, just because it can lead to more merge conflicts.

I'll keep this in mind for future patches.

Thanks,
Alex


On Tue, 2020-04-14 at 20:06 +0100, Christopher Baines wrote:
> Alexandros Theodotou <alex@zrythm.org> writes:
> 
> > These patches add 3 new LV2 plugins by the same author as
> > bsequencer:
> > bchoppr
> > bshapr
> > bjumblr
> 
> I've got a couple of comments. It looks to me like it would be
> clearer
> to not have the packages inherit from bsequencer. Some copying in the
> package definitions is fine if there are similarities between
> packages.
> 
> The second thing is that I'd try to avoid adding package definitions
> at
> the end of files, just because it can lead to more merge conflicts.
> 
> Would you be able to send some updated patches?
> 
> Thanks,
> 
> Chris
Christopher Baines May 3, 2020, 10:19 a.m. UTC | #3
Alexandros Theodotou <alex@zrythm.org> writes:

> I think these should inherit from bsequencer since these are plugins by
> the same author and it's reasonable that they follow the same build
> procedure. We already to do this for other similar situations and it
> also makes maintenance easier and DRY. Perhaps moving them below
> bsequencer would be a better solution?

Sorry for the slow reply. In terms of maintenance going forward, the
cost of inheritance is that it means that changes to one package
definition can effect others. So the question should be, should changes
to bsequencer like the inputs or arguments be applied to bchoppr as
well.

Anyway, these things become clearer with time. I've gone ahead and
pushed this (the 1.4.2 version) as
d5aee5003422c1cc4f3adfe016a24cc1b9c35881. I've moved the package up from
the bottom of the file, and tweaked the commit message (capital N in
new).

Chris
diff mbox series

Patch

From cb765aeba81d505a103203d6bfdf917fdf0b5bab Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 10 Apr 2020 13:34:17 +0100
Subject: [PATCH 1/3] gnu: Add bchoppr.

* gnu/packages/music.scm (bchoppr): new variable.
---
 gnu/packages/music.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5257d9463a..fb8c0445bb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5422,3 +5422,25 @@  plugin and a standalone JACK application.")
   offers an LV2 version ported by moddevices.")
       (home-page "http://tap-plugins.sourceforge.net/")
       (license license:gpl2))))
+
+(define-public bchoppr
+  (package
+    (inherit bsequencer)
+    (name "bchoppr")
+    (version "1.4.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/sjaehn/BChoppr.git")
+               (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "1qq1bg1p4qawhwdag0j8hvf6kdsxkyn8gdjd9pbx00p1i314mp6r"))))
+    (synopsis "Audio stream-chopping LV2 plugin")
+    (description "B.Choppr cuts the audio input stream into a repeated
+sequence of up to 16 chops.  Each chop can be leveled up or down (gating).
+B.Choppr is the successor of B.Slizr.")
+    (home-page "https://github.com/sjaehn/BChoppr")
+    (license license:gpl3+)))
-- 
2.26.0