diff mbox series

[bug#40708] gnu: font-gnu-unifont: Unify outputs for fonts.

Message ID 20200419012441.62891acb.raghavgururajan@disroot.org
State Under Review
Headers show
Series [bug#40708] gnu: font-gnu-unifont: Unify outputs for fonts. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 19, 2020, 5:24 a.m. UTC

Comments

Leo Famulari April 23, 2020, 2:30 a.m. UTC | #1
On Sun, Apr 19, 2020 at 01:24:41AM -0400, Raghav Gururajan wrote:

> From dff7acc350ba6f2e8d6ba3b561fb58acdc1a9c00 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Sun, 19 Apr 2020 01:18:41 -0400
> Subject: [PATCH 2/2] gnu: font-gnu-unifont: Unify outputs for fonts.
> 
> * gnu/package/fonts.scm (font-gnu-unifont): Unify outputs for fonts.
> 
> Let us not over-do multiple outputs. Separating fonts and binaries is
> sane enough. Also, GNU Unifont only have very few fonts in each format.

There is a significant size difference between these outputs. Is there
any prior discussion about what they are used for? Is there something to
gain by combining them?
Raghav Gururajan April 23, 2020, 2:44 a.m. UTC | #2
Hi Leo!

> There is a significant size difference between these outputs. Is there
> any prior discussion about what they are used for? Is there something to
> gain by combining them?

Not sure about discussion, but it is better to combine fonts and keep just
binaries separate. Because if a user install unifont to use in their
applications, not all of them gonna use ttf. Some apps gonna look for otf
formats. It would be confusing to install three different outputs for get all
formats.

Regards,
RG.
Leo Famulari April 23, 2020, 4:05 p.m. UTC | #3
On Wed, Apr 22, 2020 at 10:44:09PM -0400, Raghav Gururajan wrote:
> Not sure about discussion, but it is better to combine fonts and keep just
> binaries separate. Because if a user install unifont to use in their
> applications, not all of them gonna use ttf. Some apps gonna look for otf
> formats. It would be confusing to install three different outputs for get all
> formats.

Unifont provides TrueType, PCF, and PSF. It does not have OTF fonts.

Currently, if a user installs 'font-gnu-unifont' they get TrueType
fonts.

On the other hand, the PSF fonts can be used in the bootloader and the
Linux console, and they are only 68 kilobytes, rather than ~22 megabytes
if you combine all the font outputs. I don't see a compelling reason for
that increase.

If the problem is that packages with multiple outputs are confusing, we
should try to improve the UI, and we shouldn't use multiple outputs if
there isn't a good reason. But this is a case where I think it makes
sense.
Raghav Gururajan May 11, 2020, 4:54 a.m. UTC | #4
Hi Leo!

Sorry for the delayed response.

> Unifont provides TrueType, PCF, and PSF. It does not have OTF fonts.

That's correct. I was suggesting a scenario of using more than one type. :-)

> Currently, if a user installs 'font-gnu-unifont' they get TrueType
> fonts.
> 
> On the other hand, the PSF fonts can be used in the bootloader and the
> Linux console, and they are only 68 kilobytes, rather than ~22 megabytes
> if you combine all the font outputs. I don't see a compelling reason for
> that increase.

OK. I think of two reasons: 1) If one installs this package with
suggested patch, the user can use unifont for any purpose as they wish.
It may be application (ttf), console/grub (psf) and/or display server
(pcf). 2) The setup will be consistent with other font packages, where
the package installs fonts with all the types it can provide.

> If the problem is that packages with multiple outputs are confusing, we
> should try to improve the UI, and we shouldn't use multiple outputs if
> there isn't a good reason. But this is a case where I think it makes
> sense.

Improving UI would be good too. Regarding multiple outputs, I think it
is good enough to separate libs, bins and docs. In this packages, we
already separated bin and fonts. I suggest that we shall not separate
fonts further into it's subtypes. That is all I ask. :-)

Regards,
RG.
diff mbox series

Patch

From dff7acc350ba6f2e8d6ba3b561fb58acdc1a9c00 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sun, 19 Apr 2020 01:18:41 -0400
Subject: [PATCH 2/2] gnu: font-gnu-unifont: Unify outputs for fonts.

* gnu/package/fonts.scm (font-gnu-unifont): Unify outputs for fonts.

Let us not over-do multiple outputs. Separating fonts and binaries is
sane enough. Also, GNU Unifont only have very few fonts in each format.
---
 gnu/packages/fonts.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 0356d50c7c..77103bdd39 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -681,9 +681,7 @@  for use at smaller text sizes")))
        (sha256
         (base32 "1svzm3xahb2m8r79ha9gb1z3zlckykx9d87cghswj7dxn9868j4b"))))
     (build-system gnu-build-system)
-    (outputs '("out"   ; TrueType version
-               "pcf"   ; PCF (bitmap) version
-               "psf"   ; PSF (console) version
+    (outputs '("out"   ; Fonts
                "bin")) ; Utilities to manipulate '.hex' format
     (arguments
      '(#:tests? #f          ; no check target
@@ -696,11 +694,11 @@  for use at smaller text sizes")))
           'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((ttf (string-append (assoc-ref outputs "out")
-                                       "/share/fonts/truetype"))
-                   (pcf (string-append (assoc-ref outputs "pcf")
-                                       "/share/fonts/misc"))
-                   (psf (string-append (assoc-ref outputs "psf")
-                                       "/share/consolefonts"))
+                                       "/share/fonts/ttf"))
+                   (pcf (string-append (assoc-ref outputs "out")
+                                       "/share/fonts/pcf"))
+                   (psf (string-append (assoc-ref outputs "out")
+                                       "/share/fonts/psf"))
                    (bin (assoc-ref outputs "bin")))
               (invoke "make"
                       (string-append "PREFIX=" bin)
-- 
2.26.1