diff mbox series

[bug#39900] Add two Perl packages

Message ID 5c326aec3055645909de961a630abf7a05e9bb3f.camel@gnu.org
State Accepted
Headers show
Series [bug#39900] Add two Perl packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Roel Janssen March 4, 2020, 1:07 p.m. UTC
Dear Guix,

I'd like to add the attached Perl packages.  They originated from the UBC's
staging repository, and I think they are good enough for upstream Guix.

Kind regards,
Roel Janssen

Comments

Ludovic Courtès March 8, 2020, 8:15 p.m. UTC | #1
Hi Roel,

Roel Janssen <roel@gnu.org> skribis:

> From 822bb44d86053742ce80df6b663b05a142d4697c Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Wed, 4 Mar 2020 14:04:24 +0100
> Subject: [PATCH 2/2] gnu: Add perl-config-inifiles.
>
> * gnu/packages/perl.scm (perl-config-inifiles): New variable.

[...]

> From 51765c31fccf2862403e12f6a44750f76d6dcdf6 Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Wed, 4 Mar 2020 14:03:53 +0100
> Subject: [PATCH 1/2] gnu: Add perl-attribute-util.
>
> * gnu/packages/perl.scm (perl-attribute-util): New variable.

Both LGTM.  Thanks!

Ludo’.
Roel Janssen March 8, 2020, 9:07 p.m. UTC | #2
On Sun, 2020-03-08 at 21:15 +0100, Ludovic Courtès wrote:
> Hi Roel,
> 
> Roel Janssen <roel@gnu.org> skribis:
> 
> > From 822bb44d86053742ce80df6b663b05a142d4697c Mon Sep 17 00:00:00
> > 2001
> > From: Roel Janssen <roel@gnu.org>
> > Date: Wed, 4 Mar 2020 14:04:24 +0100
> > Subject: [PATCH 2/2] gnu: Add perl-config-inifiles.
> > 
> > * gnu/packages/perl.scm (perl-config-inifiles): New variable.
> 
> [...]
> 
> > From 51765c31fccf2862403e12f6a44750f76d6dcdf6 Mon Sep 17 00:00:00
> > 2001
> > From: Roel Janssen <roel@gnu.org>
> > Date: Wed, 4 Mar 2020 14:03:53 +0100
> > Subject: [PATCH 1/2] gnu: Add perl-attribute-util.
> > 
> > * gnu/packages/perl.scm (perl-attribute-util): New variable.
> 
> Both LGTM.  Thanks!

Pushed. Thanks!

Kind regards,
Roel Janssen
diff mbox series

Patch

From 51765c31fccf2862403e12f6a44750f76d6dcdf6 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Wed, 4 Mar 2020 14:03:53 +0100
Subject: [PATCH 1/2] gnu: Add perl-attribute-util.

* gnu/packages/perl.scm (perl-attribute-util): New variable.
---
 gnu/packages/perl.scm | 29 ++++++++++++++++++++++++++++-
 1 file changed, 28 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1797766db5..89ee8bc875 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9,7 +9,7 @@ 
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 ng0 <ng0@n0.is>
 ;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
-;;; Copyright © 2016, 2018 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016, 2018, 2020 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
@@ -334,6 +334,33 @@  signal running perl code from another thread, asynchronously, and
 sometimes even without using a single syscall.")
     (license (package-license perl))))
 
+(define-public perl-attribute-util
+  (package
+    (name "perl-attribute-util")
+    (version "1.07")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://cpan.metacpan.org/authors/id/D/DA/DANKOGAI/"
+                    "Attribute-Util-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1z79d845dy96lg0pxw0kr2za0gniwnpn963r7ccajfpj6k7jfw07"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/pod/Attribute::Util")
+    (synopsis "Assorted general utility attributes")
+    (description "This packages provides various utility functions.  When used
+without argument, this module provides four universally accessible attributes
+of general interest as follows:
+@itemize
+@item Abstract
+@item Alias
+@item Memoize
+@item Method
+@item SigHandler
+@end itemize")
+    (license (package-license perl))))
+
 (define-public perl-autovivification
   (package
     (name "perl-autovivification")
-- 
2.25.1