diff mbox series

[bug#39480] gnu: Add zig compiler

Message ID 11943681581079241@vla1-d97dbca235a9.qloud-c.yandex.net
State Accepted
Headers show
Series [bug#39480] gnu: Add zig compiler | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Simon Nielsen Feb. 7, 2020, 12:40 p.m. UTC
Hi,

Adds the zig compiler as a new file in `gnu/packages/`

- Simon

Comments

Leo Famulari Feb. 21, 2020, 6:07 p.m. UTC | #1
On Fri, Feb 07, 2020 at 01:40:41PM +0100, Simon Nielsen wrote:
> Hi,
> 
> Adds the zig compiler as a new file in `gnu/packages/`

Thanks! Please add it to 'gnu/local.mk'.

> +(define-public zig-0.5.0

We can name it 'zig' until there are multiple versions in Guix.

> +     `(#:tests? #f

Why are the tests disabled? Is it because there is no test suite? Or
something else? Please add a brief code comment explaining it.

> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-before 'build 'fix-build
> +           (lambda _ (setenv "HOME" "/tmp") #t)))))

I guess that the build tries to access $HOME?

> +    (description
> +      "Programming languaged designed for robustness, optimality, and clarity")

Can you try to make a more detailed description here? At least it should
be a complete sentence.

> +    (synopsis
> +      "Programming languaged designed for robustness, optimality, and clarity")

Typo: languaged
Christopher Baines Nov. 20, 2020, 8:38 p.m. UTC | #2
Leo Famulari <leo@famulari.name> writes:

> On Fri, Feb 07, 2020 at 01:40:41PM +0100, Simon Nielsen wrote:
>> Hi,
>> 
>> Adds the zig compiler as a new file in `gnu/packages/`
>
> Thanks! Please add it to 'gnu/local.mk'.
>
>> +(define-public zig-0.5.0
>
> We can name it 'zig' until there are multiple versions in Guix.
>
>> +     `(#:tests? #f
>
> Why are the tests disabled? Is it because there is no test suite? Or
> something else? Please add a brief code comment explaining it.
>
>> +       #:phases
>> +       (modify-phases %standard-phases
>> +         (add-before 'build 'fix-build
>> +           (lambda _ (setenv "HOME" "/tmp") #t)))))
>
> I guess that the build tries to access $HOME?
>
>> +    (description
>> +      "Programming languaged designed for robustness, optimality, and clarity")
>
> Can you try to make a more detailed description here? At least it should
> be a complete sentence.
>
>> +    (synopsis
>> +      "Programming languaged designed for robustness, optimality, and clarity")
>
> Typo: languaged

It's been a few months, is this patch still relevant?

Thanks,

Chris
diff mbox series

Patch

From a87eb4cbc76337a2f9ede07fae57808851ac5d45 Mon Sep 17 00:00:00 2001
From: "Simon A. Nielsen Knights" <tauoverpi@yandex.com>
Date: Fri, 7 Feb 2020 12:19:05 +0100
Subject: [PATCH] gnu: Add zig-0.5.0 compiler

---
 gnu/packages/zig.scm | 59 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)
 create mode 100644 gnu/packages/zig.scm

diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
new file mode 100644
index 0000000000..ccd8327aed
--- /dev/null
+++ b/gnu/packages/zig.scm
@@ -0,0 +1,59 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Simon A. Nielsen Knights <tauoverpiu@yandex.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages zig)
+  #:use-module (guix packages)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix download)
+  #:use-module (guix build-system cmake)
+  #:use-module (gnu packages xml)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages llvm))
+
+(define-public zig-0.5.0
+  (package
+    (version "0.5.0")
+    (name "zig")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://ziglang.org/download/"
+                                  version "/zig-"
+                                  version ".tar.xz"))
+              (sha256
+                (base32
+                  "0ccahg6bfm9m1mzr5gqs2jd5a3idj1q8akwbz6fcnaqm1yb1dbjm"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'fix-build
+           (lambda _ (setenv "HOME" "/tmp") #t)))))
+    (inputs
+      `(("llvm" ,llvm-9)
+        ("clang" ,clang-9)
+        ("libxml2" ,libxml2)
+        ("zlib" ,zlib)))
+    (description
+      "Programming languaged designed for robustness, optimality, and clarity")
+    (synopsis
+      "Programming languaged designed for robustness, optimality, and clarity")
+    (home-page "https://ziglang.org")
+    (license license:expat)))
+
+(define-public zig zig-0.5.0)
-- 
2.25.0