diff mbox series

[bug#39275] gnu: vlc: add fluidsynth as input.

Message ID 56f17e2eeb450626e36f546d80f0c63a26185c56.camel@gmail.com
State Changes Requested
Delegated to: Christopher Baines
Headers show
Series [bug#39275] gnu: vlc: add fluidsynth as input. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jesse Gibbons Jan. 25, 2020, 1:19 a.m. UTC
* gnu/packages/video.scm (vlc) [inputs]: Add FluidSynth.
---
 gnu/packages/video.scm | 1 +
 1 file changed, 1 insertion(+)

        ("freetype" ,freetype)

Comments

Christopher Baines Jan. 25, 2020, 8:35 a.m. UTC | #1
Jesse Gibbons <jgibbons2357@gmail.com> writes:

> * gnu/packages/video.scm (vlc) [inputs]: Add FluidSynth.
> ---
>  gnu/packages/video.scm | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index ee7108753f..53d9a794f8 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -1118,6 +1118,7 @@ videoformats depend on the configuration flags of
> ffmpeg.")
>         ("dbus" ,dbus)
>         ("eudev" ,eudev)
>         ("flac" ,flac)
> +       ("fluidsynth" ,fluidsynth)
>         ("ffmpeg" ,ffmpeg)
>         ("fontconfig" ,fontconfig)
>         ("freetype" ,freetype)

Hi Jesse,

It would be good to put something in the commit message about why this
is happening, as it's not obvious to me at least.

Thanks,

Chris
Danny Milosavljevic Jan. 25, 2020, 11:30 a.m. UTC | #2
Hi,

I'd prefer to change the subject to "gnu: vlc: Add MIDI support.".

> It would be good to put something in the commit message about why this
> is happening, as it's not obvious to me at least.

I disagree in general because I've seen before what that leads to:
Half the source code (the comments) end up in the commit messages instead.
Eventually (because of some merge or something) those get lost, or
(because of a new commit) those get hidden.
Now someone is going to overlook it.

So I'd put documentation into comments, except when it's ephemeral ("news").

Also, in the special case of Guix the reason why we add an input later is
"we forgot to add it earlier and it was optional to the package and thus the
package built" most of the time.  So the commit message would always be
"we forgot earlier".

In this case, vlc got MIDI support with vlc 0.9.0 (long ago) and nobody
noticed.

We could have the subject say "Add MIDI support" because it communicates more
clearly what this commit does for users.  And that's the news :)
Christopher Baines Jan. 26, 2020, 10:23 a.m. UTC | #3
Danny Milosavljevic <dannym@scratchpost.org> writes:

> Hi,
>
> I'd prefer to change the subject to "gnu: vlc: Add MIDI support.".
>
>> It would be good to put something in the commit message about why this
>> is happening, as it's not obvious to me at least.
>
> I disagree in general because I've seen before what that leads to:
> Half the source code (the comments) end up in the commit messages instead.
> Eventually (because of some merge or something) those get lost, or
> (because of a new commit) those get hidden.
> Now someone is going to overlook it.

I'm not suggesting documenting code in commit messages, just saying
something about the motivation/intention with the change is useful. The
message you suggest meets this criteria perfectly.

> So I'd put documentation into comments, except when it's ephemeral ("news").
>
> Also, in the special case of Guix the reason why we add an input later is
> "we forgot to add it earlier and it was optional to the package and thus the
> package built" most of the time.  So the commit message would always be
> "we forgot earlier".

So I would say that "we forgot earlier" isn't a motivation, or
descriptive of intent (although maybe it meets the "why this is
happening" I mentioned earlier, but that was maybe poorly explained)..

> In this case, vlc got MIDI support with vlc 0.9.0 (long ago) and nobody
> noticed.
>
> We could have the subject say "Add MIDI support" because it communicates more
> clearly what this commit does for users.  And that's the news :)

Yeah, I think that's good. At least in the context I was looking at
this, trying to review the change, knowing what the intent is allows me
to check if that's been satisfied (trying to play some MIDI content with
VLC before and after).

Chris
Jesse Gibbons Jan. 27, 2020, 12:56 a.m. UTC | #4
On Sun, 2020-01-26 at 10:23 +0000, Christopher Baines wrote:
> 	Error verifying signature: Failed to execute gpg.
> Danny Milosavljevic <dannym@scratchpost.org> writes:
> 
> > Hi,
> > 
> > I'd prefer to change the subject to "gnu: vlc: Add MIDI support.".
> > 
> > > It would be good to put something in the commit message about why
> > > this
> > > is happening, as it's not obvious to me at least.
> > 
> > I disagree in general because I've seen before what that leads to:
> > Half the source code (the comments) end up in the commit messages
> > instead.
> > Eventually (because of some merge or something) those get lost, or
> > (because of a new commit) those get hidden.
> > Now someone is going to overlook it.
> 
> I'm not suggesting documenting code in commit messages, just saying
> something about the motivation/intention with the change is useful.
> The
> message you suggest meets this criteria perfectly.
> 
> > So I'd put documentation into comments, except when it's ephemeral
> > ("news").
> > 
> > Also, in the special case of Guix the reason why we add an input
> > later is
> > "we forgot to add it earlier and it was optional to the package and
> > thus the
> > package built" most of the time.  So the commit message would
> > always be
> > "we forgot earlier".
> 
> So I would say that "we forgot earlier" isn't a motivation, or
> descriptive of intent (although maybe it meets the "why this is
> happening" I mentioned earlier, but that was maybe poorly
> explained)..
> 
> > In this case, vlc got MIDI support with vlc 0.9.0 (long ago) and
> > nobody
> > noticed.
> > 
> > We could have the subject say "Add MIDI support" because it
> > communicates more
> > clearly what this commit does for users.  And that's the news :)
> 
> Yeah, I think that's good. At least in the context I was looking at
> this, trying to review the change, knowing what the intent is allows
> me
> to check if that's been satisfied (trying to play some MIDI content
> with
> VLC before and after).
> 
> Chris

Sorry for not explaining the intention. Do you want me to send a new
patch mentioning the added MIDI support? Should I put that in the
commit title, or in a comment?
Christopher Baines Jan. 27, 2020, 8:09 a.m. UTC | #5
Jesse Gibbons <jgibbons2357@gmail.com> writes:

> On Sun, 2020-01-26 at 10:23 +0000, Christopher Baines wrote:
>> 	Error verifying signature: Failed to execute gpg.
>> Danny Milosavljevic <dannym@scratchpost.org> writes:
>>
>> > Hi,
>> >
>> > I'd prefer to change the subject to "gnu: vlc: Add MIDI support.".
>> >
>> > > It would be good to put something in the commit message about why
>> > > this
>> > > is happening, as it's not obvious to me at least.
>> >
>> > I disagree in general because I've seen before what that leads to:
>> > Half the source code (the comments) end up in the commit messages
>> > instead.
>> > Eventually (because of some merge or something) those get lost, or
>> > (because of a new commit) those get hidden.
>> > Now someone is going to overlook it.
>>
>> I'm not suggesting documenting code in commit messages, just saying
>> something about the motivation/intention with the change is useful.
>> The
>> message you suggest meets this criteria perfectly.
>>
>> > So I'd put documentation into comments, except when it's ephemeral
>> > ("news").
>> >
>> > Also, in the special case of Guix the reason why we add an input
>> > later is
>> > "we forgot to add it earlier and it was optional to the package and
>> > thus the
>> > package built" most of the time.  So the commit message would
>> > always be
>> > "we forgot earlier".
>>
>> So I would say that "we forgot earlier" isn't a motivation, or
>> descriptive of intent (although maybe it meets the "why this is
>> happening" I mentioned earlier, but that was maybe poorly
>> explained)..
>>
>> > In this case, vlc got MIDI support with vlc 0.9.0 (long ago) and
>> > nobody
>> > noticed.
>> >
>> > We could have the subject say "Add MIDI support" because it
>> > communicates more
>> > clearly what this commit does for users.  And that's the news :)
>>
>> Yeah, I think that's good. At least in the context I was looking at
>> this, trying to review the change, knowing what the intent is allows
>> me
>> to check if that's been satisfied (trying to play some MIDI content
>> with
>> VLC before and after).
>>
>> Chris
>
> Sorry for not explaining the intention. Do you want me to send a new
> patch mentioning the added MIDI support? Should I put that in the
> commit title, or in a comment?

Sending a new patch would be great. Adding something anywhere in the
commit message is fine by me.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ee7108753f..53d9a794f8 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1118,6 +1118,7 @@  videoformats depend on the configuration flags of
ffmpeg.")
        ("dbus" ,dbus)
        ("eudev" ,eudev)
        ("flac" ,flac)
+       ("fluidsynth" ,fluidsynth)
        ("ffmpeg" ,ffmpeg)
        ("fontconfig" ,fontconfig)