diff mbox series

[bug#36060] services: cups: Create /var/cache on activation.

Message ID 6814c5b5-f2a1-4a9f-99bf-a37be2af1427@www.fastmail.com
State Accepted
Headers show
Series [bug#36060] services: cups: Create /var/cache on activation. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alex Griffin June 3, 2019, 8:01 p.m. UTC
Maybe this patch fits in a little better. I used mkdir-p/perms like the surrounding code instead of just mkdir-p.

Comments

Ludovic Courtès June 5, 2019, 3:17 p.m. UTC | #1
Hi Alex,

"Alex Griffin" <a@ajgrf.com> skribis:

> From 2ef61ab79cb387e00317cda54d893c061d9a1206 Mon Sep 17 00:00:00 2001
> From: Alex Griffin <a@ajgrf.com>
> Date: Sun, 2 Jun 2019 16:26:47 -0500
> Subject: [PATCH] services: cups: Create /var/cache on activation.
>
> * gnu/services/cups.scm (%cups-activation): Create /var/cache if it doesn't
> exist yet.

Applied, thanks!

Ludo'.
diff mbox series

Patch

From 2ef61ab79cb387e00317cda54d893c061d9a1206 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sun, 2 Jun 2019 16:26:47 -0500
Subject: [PATCH] services: cups: Create /var/cache on activation.

* gnu/services/cups.scm (%cups-activation): Create /var/cache if it doesn't
exist yet.
---
 gnu/services/cups.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
index 9125139ef3..9d21b6e70c 100644
--- a/gnu/services/cups.scm
+++ b/gnu/services/cups.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2016 Andy Wingo <wingo@pobox.com>
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -895,6 +896,7 @@  IPP specifications.")
           (mkdir-p/perms "/var/spool/cups" user #o755)
           (mkdir-p/perms "/var/spool/cups/tmp" user #o755)
           (mkdir-p/perms "/var/log/cups" user #o755)
+          (mkdir-p/perms "/var/cache/cups" user #o770)
           (mkdir-p/perms "/etc/cups" user #o755)
           (mkdir-p/perms "/etc/cups/ssl" user #o700)
           ;; This certificate is used for HTTPS connections to the CUPS web
-- 
2.21.0