diff mbox series

[bug#35952] gnu: Add python-aniso8601.

Message ID 20190528120539.4603-1-h.nasajpour@pantherx.org
State Accepted
Headers show
Series [bug#35952] gnu: Add python-aniso8601. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Hamzeh Nasajpour May 28, 2019, 12:05 p.m. UTC
* gnu/packages/python-xyz.scm (python-aniso8601): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

Brett Gilio Dec. 10, 2019, 6:27 a.m. UTC | #1
"h.nasajpour" <h.nasajpour@pantherx.org> writes:

> * gnu/packages/python-xyz.scm (python-aniso8601): New variable.
> ---
>  gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
>  1 file changed, 18 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index ec49359314..91f94f239e 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -15391,3 +15391,21 @@ by Igor Pavlov.")
>  
>  (define-public python2-pylzma
>    (package-with-python2 python-pylzma))
> +
> +(define-public python-aniso8601
> +  (package
> +  (name "python-aniso8601")
> +    (version "6.0.0")
> +    (source (origin
> +      (method url-fetch)
> +      (uri (pypi-uri "aniso8601" version))
> +      (sha256 (base32 "1bylfskk08ahyma25i8w3mcd0kywpxqx6icv5p7m1z0i8srak9mq"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:tests? #f))
> +    (home-page "https://bitbucket.org/nielsenb/aniso8601")
> +    (synopsis "A library for parsing ISO 8601 strings.")
> +    (description
> +     "A library for parsing ISO 8601 strings.")
> +    (license license:expat)))
> +

Closing. This is a redundant package. If you meant to update it please
send a revised patch in a new bug report reflecting the 8.0.0 upstream
version.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ec49359314..91f94f239e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15391,3 +15391,21 @@  by Igor Pavlov.")
 
 (define-public python2-pylzma
   (package-with-python2 python-pylzma))
+
+(define-public python-aniso8601
+  (package
+  (name "python-aniso8601")
+    (version "6.0.0")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "aniso8601" version))
+      (sha256 (base32 "1bylfskk08ahyma25i8w3mcd0kywpxqx6icv5p7m1z0i8srak9mq"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))
+    (home-page "https://bitbucket.org/nielsenb/aniso8601")
+    (synopsis "A library for parsing ISO 8601 strings.")
+    (description
+     "A library for parsing ISO 8601 strings.")
+    (license license:expat)))
+