diff mbox series

[bug#37741,1/3] gnu: u-boot: Update to 2019.10.

Message ID 20191014060105.31091-1-nomble@palism.com
State Accepted
Headers show
Series Update u-boot to 2019.10 and add u-boot-rockpro64-rk3399. | expand

Commit Message

nomble@palism.com Oct. 14, 2019, 6:01 a.m. UTC
From: Caliph Nomble <nomble@palism.com>

* gnu/packages/bootloaders.scm (u-boot): Update to 2019.10.
[source]: Remove upstreamed patches.
* gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch: Delete
file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Caliph Nomble <nomble@palism.com>
---
 gnu/local.mk                                  |  1 -
 gnu/packages/bootloaders.scm                  |  7 +--
 ...boot-fix-mkimage-header-verification.patch | 57 -------------------
 3 files changed, 2 insertions(+), 63 deletions(-)
 delete mode 100644 gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch

Comments

Vagrant Cascadian Oct. 15, 2019, 4:07 a.m. UTC | #1
On 2019-10-14, nomble@palism.com wrote:
> From: Caliph Nomble <nomble@palism.com>
>
> * gnu/packages/bootloaders.scm (u-boot): Update to 2019.10.
> [source]: Remove upstreamed patches.
> * gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch: Delete
> file.
> * gnu/local.mk (dist_patch_DATA): Remove it.

Thanks for working on this!

I've been holding back on updating u-boot in Guix, as there are several
unresolved bugs on other platforms, and the u-boot-tools package fails
tests, last I tried.

Might make sense to make versioned u-boot-2019.04 and u-boot-2019.10
packages (kind of like the linux-libre packages, possibly?), so that
platforms that still need to use the older version don't hold back
platforms that need or would benefit from the newer version?


live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 39b8e009b2..428708c9fe 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1371,7 +1371,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/totem-meson-easy-codec.patch		\
   %D%/packages/patches/tuxpaint-stamps-path.patch		\
   %D%/packages/patches/txr-shell.patch				\
-  %D%/packages/patches/u-boot-fix-mkimage-header-verification.patch	\
   %D%/packages/patches/unzip-CVE-2014-8139.patch		\
   %D%/packages/patches/unzip-CVE-2014-8140.patch		\
   %D%/packages/patches/unzip-CVE-2014-8141.patch		\
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 520728b52c..91f27d2e38 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -400,7 +400,7 @@  tree binary files.  These are board description files used by Linux and BSD.")
 (define u-boot
   (package
     (name "u-boot")
-    (version "2019.04")
+    (version "2019.10")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -408,10 +408,7 @@  tree binary files.  These are board description files used by Linux and BSD.")
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "1vwv4bgbl7fjcm073zrphn17hnz5h5h778f88ivdsgbb2lnpgdvn"))
-              (patches
-               (search-patches
-                "u-boot-fix-mkimage-header-verification.patch"))))
+                "053hcrwwlacqh2niisn0zas95zkbffw5aw5sdhixs8lmfdq60vcd"))))
     (native-inputs
      `(("bc" ,bc)
        ("bison" ,bison)
diff --git a/gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch b/gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch
deleted file mode 100644
index 063677db4a..0000000000
--- a/gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch
+++ /dev/null
@@ -1,57 +0,0 @@ 
-From 48b52117235928cfd7ef1ec5c3f2cff5d7b03862 Mon Sep 17 00:00:00 2001
-From: Jordan Hand <jordanhand22@gmail.com>
-Date: Wed, 10 Apr 2019 09:46:32 -0700
-Subject: [PATCH,v2] fdt: Fix mkimage list to try every header type
-Origin: https://patchwork.ozlabs.org/patch/1083495/
-
-Image type is not supplied to `mkimage -l`. For this reason, we cannot
-use imagetool_verify_print_header_by_type. Instead, this patch uses
-imagetool_verify_print_header to look through all header types to find
-one where image validation succeeds.
-
-This patch fixes failures in test/image/test-imagetools.sh
-
-Signed-off-by: Jordan Hand <jorhand@microsoft.com>
-Tested-by: Alex Kiernan <alex.kiernan@gmail.com>
-Tested-by: Vagrant Cascadian <vagrant@debian.org>
----
- tools/mkimage.c | 23 +++++++++++++++--------
- 1 file changed, 15 insertions(+), 8 deletions(-)
-
-diff --git a/tools/mkimage.c b/tools/mkimage.c
-index 2899adff81..76c3406d37 100644
---- a/tools/mkimage.c
-+++ b/tools/mkimage.c
-@@ -403,14 +403,21 @@ int main(int argc, char **argv)
- 			exit (EXIT_FAILURE);
- 		}
- 
--		/*
--		 * scan through mkimage registry for all supported image types
--		 * and verify the input image file header for match
--		 * Print the image information for matched image type
--		 * Returns the error code if not matched
--		 */
--		retval = imagetool_verify_print_header_by_type(ptr, &sbuf,
--				tparams, &params);
-+		if (params.fflag) {
-+			/*
-+			 * Verifies the header format based on the expected header for
-+			 * image type in tparams
-+			 */
-+			retval = imagetool_verify_print_header_by_type(ptr, &sbuf,
-+					tparams, &params);
-+		} else {
-+			/**
-+			 * When listing the image, we are not given the image type. Simply check all
-+			 * image types to find one that matches our header
-+			 */
-+			retval = imagetool_verify_print_header(ptr, &sbuf,
-+					tparams, &params);
-+		}
- 
- 		(void) munmap((void *)ptr, sbuf.st_size);
- 		(void) close (ifd);
--- 
-2.20.1
-