diff mbox series

[bug#36545] Add Hoogle

Message ID CAKf5CqXs_hf9OTFGLezBvX5MeRO4HEPizEon2kCwwU7W-puuzA@mail.gmail.com
State Accepted
Headers show
Series [bug#36545] Add Hoogle | expand

Commit Message

John Soo July 8, 2019, 6:10 a.m. UTC
Hi Guix,

Hoogle is a search tool that is invaluable when writing Haskell.  I have
linted, formatted, and built --rounds=2 all the following.

Thank you,

John

Comments

Robert Vollmert July 9, 2019, 5:37 p.m. UTC | #1
Hi John,

indeed hoogle would be nice to have. Thanks for packagin it!

Two remarks from looking over the patch set:

- ghc-mtl shouldn’t be packaged, as it’s a GHC-bundled library. New
versions of `guix import` were updated to take that into account
properly, but it should “just work” to remove patch 0001 and delete
the dependency lines for `ghc-mtl` where they occur.

- Is there a particular reason that tests are disabled? The general
approach seems to be to build packages with tests unless there’s a
specific reason not to, in which case it would be great if you could
add a comment explaining that next to the “#:tests? #f” line.

Cheers
Robert
diff mbox series

Patch

From 178b2deab3c7c755d37d46a2711e8e130c2c22ce Mon Sep 17 00:00:00 2001
From: John Soo <jsoo@panosoft.com>
Date: Sun, 7 Jul 2019 18:01:54 -0700
Subject: [PATCH 12/13] gnu: Add ghc-js-flot.

---
 gnu/packages/haskell-web.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 57bcc4b027..3655a5a7d9 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1373,3 +1373,29 @@  first three components of the version number match the upstream jQuery version.
 The package is designed to meet the redistribution requirements of downstream
 users (e.g. Debian).")
     (license license:expat)))
+
+(define-public ghc-js-flot
+  (package
+    (name "ghc-js-flot")
+    (version "0.8.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append
+         "https://hackage.haskell.org/package/js-flot/js-flot-"
+         version ".tar.gz"))
+       (sha256
+        (base32
+         "0yjyzqh3qzhy5h3nql1fckw0gcfb0f4wj9pm85nafpfqp2kg58hv"))))
+    (build-system haskell-build-system)
+    (arguments `(#:tests? #f))
+    (home-page "https://github.com/ndmitchell/js-flot#readme")
+    (synopsis "Obtain minified flot code")
+    (description
+     "This package bundles the minified Flot code (http://www.flotcharts.org/)
+(a jQuery plotting library) into a Haskell package, so it can be depended upon
+by Cabal packages.  The first three components of the version number match the
+upstream flot version.  The package is designed to meet the redistribution
+requirements of downstream users (e.g. Debian).")
+    (license license:expat)))
-- 
2.22.0