[bug#33789] gnu: python-rdflib: Update to 4.2.2.

Message ID 20181218120209.8749-1-pjotr.public12@thebird.nl
State Accepted
Headers show
Series [bug#33789] gnu: python-rdflib: Update to 4.2.2. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Pjotr Prins Dec. 18, 2018, 12:02 p.m. UTC
From: Pjotr Prins <pjotr.public01@thebird.nl>

* gnu/packages/rdf.scm (python-rdflib): Update to 4.2.2.
---
 gnu/packages/rdf.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès Dec. 18, 2018, 3:04 p.m. UTC | #1
Hi Pjotr,

Pjotr Prins <pjotr.public12@thebird.nl> skribis:

> From: Pjotr Prins <pjotr.public01@thebird.nl>
>
> * gnu/packages/rdf.scm (python-rdflib): Update to 4.2.2.

Looks like the patch that appears in the ‘origin’ no longer applies:

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix build python{,2}-rdflib --substitute-urls=https://berlin.guixsd.org --no-build-hook
building /gnu/store/813y7l90ys3wslqnm6rkdp6y38isikfy-python2-isodate-0.5.4.drv...

[…]

patching file setup.py
Hunk #1 FAILED at 52.
1 out of 1 hunk FAILED -- saving rejects to file setup.py.rej

[…]

builder for `/gnu/store/5p5zibpvahw5ps45zw1115ir063kqhxp-rdflib-4.2.2.tar.xz.drv' failed with exit code 1
build of /gnu/store/5p5zibpvahw5ps45zw1115ir063kqhxp-rdflib-4.2.2.tar.xz.drv failed
--8<---------------cut here---------------end--------------->8---

Could you send an updated patch?

Thank you!

Ludo’.

Patch

diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 22ea21dd9..720c50362 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -299,7 +299,7 @@  ideal (e.g. in LV2 implementations or embedded applications).")
 (define-public python-rdflib
   (package
     (name "python-rdflib")
-    (version "4.1.2")
+    (version "4.2.2")
     (source
       (origin
         (method url-fetch)
@@ -308,14 +308,15 @@  ideal (e.g. in LV2 implementations or embedded applications).")
               version
               ".tar.gz"))
         (patches
-          ;; The patch has no effect under Python 3.
+          ;; The patch has no effect under Python 3. Note the
+          ;; dependency has been removed on trunk
           (search-patches "python2-rdflib-drop-sparqlwrapper.patch"))
         (sha256
           (base32
-            "0kvaf332cqbi47rqzlpdx4mbkvw12mkrzkj8n9l19wk713d4py9w"))))
+            "0398c714znnhaa2x7v51b269hk20iz073knq2mvmqp2ma92z27fs"))))
     (build-system python-build-system)
     (arguments
-     '(;; FIXME: Three test failures. Try uncommenting the below next update.
+     '(;; FIXME: Three test failures. Should be fixed next release.
        #:tests? #f))
        ;; #:phases
        ;; (modify-phases %standard-phases
@@ -323,7 +324,7 @@  ideal (e.g. in LV2 implementations or embedded applications).")
        ;;     (lambda _
        ;;       ;; Run tests from the build directory so python3 only
        ;;       ;; sees the installed 2to3 version.
-       ;;       (zero? (system* "nosetests" "--where=./build/src")))))
+       ;;       (zero? (system* "nosetests" "--where=./build/src")))))))
     (native-inputs
      `(("python-nose" ,python-nose)))
     (propagated-inputs