[bug#33351] gnu: xonotic: Symlink to xonotic data instead of copying into xonotic.

Message ID E1gM35s-00079t-V8@rmmprod06.runbox
State Accepted
Headers show
Series [bug#33351] gnu: xonotic: Symlink to xonotic data instead of copying into xonotic. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

pkill9 Nov. 12, 2018, 3:40 a.m. UTC
This patch changes the 'install-data phase of the xonotic package so that it creates a symlink to xonotic's data ('xonotic-data' package) instead of copying it. This reduces the package download size from 880mb to 12mb.

The xonotic-data package is already an input in the xonotic package rather than a native-input, so that didn't need to be changed.

Comments

Ludovic Courtès Nov. 19, 2018, 9:40 p.m. UTC | #1
Hello,

<pkill9@runbox.com> skribis:

> This patch changes the 'install-data phase of the xonotic package so that it creates a symlink to xonotic's data ('xonotic-data' package) instead of copying it. This reduces the package download size from 880mb to 12mb.

Good catch.

> The xonotic-data package is already an input in the xonotic package rather than a native-input, so that didn't need to be changed.
>
> From 0396ed08ca9fe936e2a89f830fbee1ecfc408b9b Mon Sep 17 00:00:00 2001
> From: Pkill -9 <pkill9@runbox.com>
> Date: Mon, 12 Nov 2018 03:14:15 +0000
> Subject: [PATCH] gnu: xonotic: Symlink to xonotic data instead of copying into
>  xonotic.
>
> * gnu/packages/games.scm (xonotic)[arguments]: Modify the phase
> 'install-data so it creates a symlink to xonotic's data instead of
> copying it into the xonotic package.

Applied, thanks!

Ludo’.

Patch

From 0396ed08ca9fe936e2a89f830fbee1ecfc408b9b Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Mon, 12 Nov 2018 03:14:15 +0000
Subject: [PATCH] gnu: xonotic: Symlink to xonotic data instead of copying into
 xonotic.

* gnu/packages/games.scm (xonotic)[arguments]: Modify the phase
'install-data so it creates a symlink to xonotic's data instead of
copying it into the xonotic package.
---
 gnu/packages/games.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3679aa09c..bc5d3d581 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5606,8 +5606,8 @@  quotation from a collection of quotes.")
            (lambda* (#:key outputs inputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (data (assoc-ref inputs "xonotic-data")))
-               (copy-recursively (string-append data "/share/xonotic")
-                                 (string-append out "/share/xonotic"))
+               (symlink (string-append data "/share/xonotic")
+                        (string-append out "/share/xonotic"))
                #t)))
          (add-after 'install-binaries 'wrap-binaries
            (lambda* (#:key outputs inputs #:allow-other-keys)
-- 
2.19.1