diff mbox series

[bug#36064] sawfish.scm - update sawfish to 1.12

Message ID 87imtnsgqb.fsf@jnanam.net
State Accepted
Headers show
Series [bug#36064] sawfish.scm - update sawfish to 1.12 | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Benjamin Slade June 2, 2019, 11:35 p.m. UTC

Comments

Arun Isaac June 4, 2019, 1 p.m. UTC | #1
Thanks for contributing to Guix!

Please split this into three separate patches -- one each for librep,
rep-gtk and sawfish. For the commit messages, please use the
conventional Guix update commit message. If you use Emacs, this can be
done easily using the update yasnippet in etc/snippets of the Guix
source tree.

> -    (home-page "http://sawfish.wikia.com/wiki/Librep")
> +    (home-page "https://sawfish.wikia.com/wiki/Librep")

Shouldn't https://sawfish.tuxfamily.org/ be the home-page for all three
packages? Why are we listing the wiki as the home-page?

>  (define-public rep-gtk
>    (package
>      (name "rep-gtk")
> -    (version "0.90.8.2")
> +    (version "0.90.8.2") ; next point release hasn't been distributed; requires autoconf etc.

We don't usually package beta releases. So, there is no need to mention
this as a comment. But, the current release is 0.90.8.3. Please update
to that.

>  (define-public sawfish
>    (package
>      (name "sawfish")
> -    (version "1.11")
> +    (version "1.12.0") ; point release 1.12.90 hasn't been distributed; requires autoconf etc.

We don't usually package beta releases. So, there is no need to mention
this as a comment.

> -    (home-page "http://sawfish.wikia.com/wiki/Main_Page")
> +    (home-page "https://sawfish.wikia.com/wiki/Main_Page")

See above for comment on home-page.
Benjamin Slade June 10, 2019, 6:36 a.m. UTC | #2
On 2019-06-04T07:00:35-0600, Arun Isaac <arunisaac@systemreboot.net> wrote:
 > Thanks for contributing to Guix!

Hi Arun,

Thanks for the feedback.

 > Please split this into three separate patches -- one each for librep,
 > rep-gtk and sawfish. For the commit messages, please use the
 > conventional Guix update commit message. If you use Emacs, this can
 > be done easily using the update yasnippet in etc/snippets of the Guix
 > source tree.

I'll do so.

 > > -    (home-page "http://sawfish.wikia.com/wiki/Librep")
 > > +    (home-page "https://sawfish.wikia.com/wiki/Librep")

 > Shouldn't https://sawfish.tuxfamily.org/ be the home-page for all
 > three packages? Why are we listing the wiki as the home-page?

I just followed the previous version, updating to 'https'. But
https://sawfish.tuxfamily.org/ doesn't actually have information
directly about Librep, while the wiki page the previous commit linked to
does provide information about the package.

 > >  (define-public rep-gtk
 > >    (package
 > >      (name "rep-gtk")
 > > -    (version "0.90.8.2")
 > > +    (version "0.90.8.2") ; next point release hasn't been distributed; requires autoconf etc.

 > We don't usually package beta releases. So, there is no need to
 > mention this as a comment. But, the current release is
 > 0.90.8.3. Please update to that.

0.90.8.3 isn't packaged for distribution though, so it may be
beta-ish. In any case, I don't know how to get it to build, given that
it's not packaged for distribution at this point.

 > >  (define-public sawfish
 > >    (package
 > >      (name "sawfish")
 > > -    (version "1.11")
 > > +    (version "1.12.0") ; point release 1.12.90 hasn't been distributed; requires autoconf etc.

 > We don't usually package beta releases. So, there is no need to
 > mention this as a comment.

 > > -    (home-page "http://sawfish.wikia.com/wiki/Main_Page")
 > > +    (home-page "https://sawfish.wikia.com/wiki/Main_Page")

 > See above for comment on home-page.

Effectively, then, I'm just updating `sawfish` itself, given the lack of
a need for the comments I had made about versions, so I'll resubmit a
patch just updating the sawfish package.

--
Dr Benjamin Slade - https://babbagefiles.xyz
  `(pgp_fp: ,(21BA 2AE1 28F6 DF36 110A 0E9C A320 BBE8 2B52 EE19))
    '(sent by mu4e on Emacs running under GNU/Linux . https://gnu.org )
Arun Isaac June 27, 2019, 6:58 a.m. UTC | #3
> 0.90.8.3 isn't packaged for distribution though, so it may be
> beta-ish. In any case, I don't know how to get it to build, given that
> it's not packaged for distribution at this point.

The sawfish website lists 0.90.8.3 as current. So, I think we should
update. I did this, and pushed my changes to master.

> Effectively, then, I'm just updating `sawfish` itself, given the lack of
> a need for the comments I had made about versions, so I'll resubmit a
> patch just updating the sawfish package.

I edited your earlier patch to only update sawfish, and pushed it to
master.

Thanks!
diff mbox series

Patch

From 59c8784ffb33cdce08574d13ac8675c5e3c50b1d Mon Sep 17 00:00:00 2001
From: Benjamin Slade <slade@jnanam.net>
Date: Sun, 2 Jun 2019 17:21:21 -0600
Subject: [PATCH] sawfish.scm - update sawfish to 1.12

---
 gnu/packages/sawfish.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/gnu/packages/sawfish.scm b/gnu/packages/sawfish.scm
index 1ac72f2baa..4a475eb06e 100644
--- a/gnu/packages/sawfish.scm
+++ b/gnu/packages/sawfish.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Benjamin Slade <slade@jnanam.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -41,7 +42,7 @@ 
     (version "0.92.7")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://download.tuxfamily.org/" name "/"
+              (uri (string-append "https://download.tuxfamily.org/" name "/"
                                   name "_" version ".tar.xz"))
               (sha256
                (base32
@@ -50,7 +51,6 @@ 
     (native-inputs
      `(("makeinfo"   ,texinfo)
        ("pkg-config" ,pkg-config)
-
        ("autoconf" ,autoconf-wrapper)
        ("automake" ,automake)
        ("libtool"  ,libtool)))
@@ -63,7 +63,7 @@ 
      (list (search-path-specification
             (variable "REP_DL_LOAD_PATH")
             (files '("lib/rep")))))
-    (home-page "http://sawfish.wikia.com/wiki/Librep")
+    (home-page "https://sawfish.wikia.com/wiki/Librep")
     (synopsis "Lisp system for sawfish")
     (description
      "Librep is a dialect of Lisp, designed to be used both as an extension
@@ -77,7 +77,7 @@  implementing both small and large scale systems.")
 (define-public rep-gtk
   (package
     (name "rep-gtk")
-    (version "0.90.8.2")
+    (version "0.90.8.2") ; next point release hasn't been distributed; requires autoconf etc.
     (source (origin
               (method url-fetch)
               (uri (string-append "http://download.tuxfamily.org/librep/"
@@ -111,14 +111,14 @@  backend of Sawfish.")
 (define-public sawfish
   (package
     (name "sawfish")
-    (version "1.11")
+    (version "1.12.0") ; point release 1.12.90 hasn't been distributed; requires autoconf etc.
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://download.tuxfamily.org/sawfish/"
+              (uri (string-append "https://download.tuxfamily.org/sawfish/"
                                   name "_" version ".tar.xz"))
               (sha256
                (base32
-                "0wp4m0p836a0rysbcdqb6z5hxlxqj3rgdbks3bs44rlssx0mcvyg"))
+                "1z7awzgw8d15aw17kpbj460pcxq8l2rhkaxk47w7yg9qrmg0xja4"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -172,7 +172,7 @@  backend of Sawfish.")
        ("libxrandr"   ,libxrandr)
        ("libxtst"     ,libxtst)
        ("rep-gtk"     ,rep-gtk)))
-    (home-page "http://sawfish.wikia.com/wiki/Main_Page")
+    (home-page "https://sawfish.wikia.com/wiki/Main_Page")
     (synopsis "Configurable window manager")
     (description
      "Sawfish is an extensible window manager using a Lisp-based scripting
-- 
2.21.0