diff mbox series

[bug#36096] gnu: Update neovim to 0.3.7.

Message ID 20190605131455.25131-1-jonathan.brielmaier@web.de
State Accepted
Headers show
Series [bug#36096] gnu: Update neovim to 0.3.7. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Jonathan Brielmaier June 5, 2019, 1:14 p.m. UTC
* gnu/packages/vim.scm (neovim): Update to 0.3.7.

This includes a fix for a security issue described here:
https://github.com/numirias/security/blob/master/doc/2019-06-04_ace-vim-neovim.md
---
 gnu/packages/vim.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

--
2.21.0

Comments

Ricardo Wurmus June 5, 2019, 1:25 p.m. UTC | #1
Hi Jonathan,

> * gnu/packages/vim.scm (neovim): Update to 0.3.7.
>
> This includes a fix for a security issue described here:
> https://github.com/numirias/security/blob/master/doc/2019-06-04_ace-vim-neovim.md

Thank you.  I pushed this to the master branch with commit 3390ac619f
after adjusting the commit message.
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 8789060b3c..aa543b68d0 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -730,7 +730,7 @@  are detected, the user is notified.")))
 (define-public neovim
   (package
     (name "neovim")
-    (version "0.3.5")
+    (version "0.3.7")
     (source
      (origin
        (method git-fetch)
@@ -740,7 +740,7 @@  are detected, the user is notified.")))
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "113lrr9gwimvvzlkwlishm4cjqcf30xq9jfxn7vh41ckgnbiwf3w"))))
+         "1j6w5jvq5v7kf7diad91qs1acr427nidnk9s24yyrz0hwdd1c2lh"))))
     (build-system cmake-build-system)
     (arguments
      `(#:modules ((srfi srfi-26)