diff mbox series

[bug#35944] gnu: packages: haskell: happy: Disable tests

Message ID 20190528124101.63429-1-rob@vllmrt.net
State Accepted
Headers show
Series [bug#35944] gnu: packages: haskell: happy: Disable tests | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Robert Vollmert May 28, 2019, 12:41 p.m. UTC
Tests fail reliably for me on a system with 2GB of available RAM, in
`issue93.a.hs` and `issue93.n.hs`.

* gnu/packages/haskell.scm (ghc-happy): Disable tests
---
 gnu/packages/haskell.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Ludovic Courtès June 1, 2019, 12:55 p.m. UTC | #1
Robert Vollmert <rob@vllmrt.net> skribis:

> Tests fail reliably for me on a system with 2GB of available RAM, in
> `issue93.a.hs` and `issue93.n.hs`.

They fail because they run out of memory?

What would it take to skip just these two tests instead of skipping all
the tests?

Thanks,
Ludo’.
Ludovic Courtès June 1, 2019, 9:30 p.m. UTC | #2
Hi,

Robert Vollmert <rob@vllmrt.net> skribis:

> Below is a patch that does that. I’m now running into similar issues when
> compiling ghc-scientific; should OOM test failures at 2G of memory generally
> be considered worth fixing?

I’d say yes, as long as we’re just talking about a small fraction of the
GHC packages.

> As an alternative, would it be feasible to implement a --skip-tests
> flag for guix build?

That would amount to building a different derivation, so that’s not
really a solution.

> From 7b7029d99df7df2ccdbfb4026edd91daa2a5763e Mon Sep 17 00:00:00 2001
> From: Robert Vollmert <rob@vllmrt.net>
> Date: Tue, 28 May 2019 21:10:24 +0200
> Subject: [PATCH] gnu: ghc-happy: Skip memory-hungry tests.
>
> Tests fail reliably for me on a system with 2GB of available RAM, in
> `issue93.a.hs` and `issue93.n.hs`.
>
> * gnu/packages/haskell.scm (ghc-happy): Skip test "issue93".

I copied the explanation as a comment and applied.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 33c9c6484d..7ef32537c8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1325,6 +1325,8 @@  postfix notation.  For more information on stack based languages, see
         (base32
          "138xpxdb7x62lpmgmb6b3v3vgdqqvqn4273jaap3mjmc2gla709y"))))
     (build-system haskell-build-system)
+    (arguments
+      `(#:tests? #f)) ; Test require excessive amounts of memory
     (home-page "https://hackage.haskell.org/package/happy")
     (synopsis "Parser generator for Haskell")
     (description "Happy is a parser generator for Haskell.  Given a grammar