diff mbox series

[bug#36005] gnu: Add emacs-ivy-pass

Message ID 87blzkdpox.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#36005] gnu: Add emacs-ivy-pass | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

LaFreniere, Joseph May 30, 2019, 1:42 p.m. UTC
A patch to add a the package emacs-ivy-pass is attached.

--
Joseph LaFreniere

Comments

Ricardo Wurmus May 31, 2019, 7:58 a.m. UTC | #1
Hi Joseph,

> A patch to add a the package emacs-ivy-pass is attached.

Thank you for the patch.  I applied it to the master branch with commit
b0eaead510.

(In the future, could you please send git formatted patches of commits?
This would make it easier to apply and to retain authorship information.)

--
Ricardo
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6f74a2fc45..de6804682a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4403,6 +4403,33 @@  splitting the input text by spaces and re-building it into a regular
 expression.")
     (license license:gpl3+)))
 
+(define-public emacs-ivy-pass
+  (let ((commit "5b523de1151f2109fdd6a8114d0af12eef83d3c5")
+        (revision "1"))
+    (package
+      (name "emacs-ivy-pass")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ecraven/ivy-pass.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "18crb4zh2pjf0cmv3b913m9vfng27girjwfqc3mk7vqd1r5a49yk"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-ivy" ,emacs-ivy)
+         ("emacs-password-store" ,emacs-password-store)
+         ("password-store" ,password-store)))
+      (home-page "https://github.com/ecraven/ivy-pass")
+      (synopsis "Ivy interface for password store (pass)")
+      (description "This package provides an Ivy interface for working with
+@code{pass}.")
+      (license license:gpl3))))
+
 (define-public emacs-ivy-yasnippet
   (let ((commit "32580b4fd23ebf9ca7dde96704f7d53df6e253cd")
         (revision "2"))