[bug#33354] gnu: Add libfdk 'FDK AAC' library.

Message ID 65bdefb3688267096cea52243618e5a08fb6d336.1542043329.git.leo@famulari.name
State Accepted
Headers show
Series [bug#33354] gnu: Add libfdk 'FDK AAC' library. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Leo Famulari Nov. 12, 2018, 5:22 p.m. UTC
* gnu/packages/video.scm (libfdk): New variable.
---
 gnu/packages/video.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Ludovic Courtès Nov. 16, 2018, 10:05 p.m. UTC | #1
Hello,

Leo Famulari <leo@famulari.name> skribis:

> * gnu/packages/video.scm (libfdk): New variable.

LGTM, thanks!

Ludo’.
Leo Famulari Nov. 18, 2018, 11:42 p.m. UTC | #2
On Fri, Nov 16, 2018 at 11:05:14PM +0100, Ludovic Courtès wrote:
> Hello,
> 
> Leo Famulari <leo@famulari.name> skribis:
> 
> > * gnu/packages/video.scm (libfdk): New variable.
> 
> LGTM, thanks!

Pushed as 5c40a69f7123f8f6ec4f1792bea73bb345a445b0, thanks for the
review!

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 94c5cf3a6..041cd5932 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3076,3 +3076,37 @@  as surfing, skiing, riding and walking while shooting videos are especially
 prone to erratic camera shakes.  Vidstab targets these video contents to help
 create smoother and stable videos.")
     (license license:gpl2+)))
+
+(define-public libfdk
+  (let ((commit "2326faaf8f2cdf2c3a9108ccdaf1d7551aec543e")
+        (revision "0"))
+    (package
+      (name "libfdk")
+      ;; The latest upstream revision, with many bug fixes.
+      (version (git-version "0.1.6" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/mstorsjo/fdk-aac")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+           (base32
+            "0yy6ndd9d61bwl283vl1r5kva2a4acc0f4r9g0sza156f2abr9ws"))))
+      (build-system gnu-build-system)
+      (native-inputs
+       `(("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ("libtool" ,libtool)))
+      (home-page "https://github.com/mstorsjo/fdk-aac")
+      (synopsis "Fraunhofer FDK AAC library")
+      (description "FDK is a library for encoding and decoding Advanced Audio
+Coding (AAC) format audio, developed by Fraunhofer IIS, and included as part of
+Android.  It supports several Audio Object Types including MPEG-2 and MPEG-4 AAC
+LC, HE-AAC (AAC LC + SBR), HE-AACv2 (LC + SBR + PS) as well AAC-LD (low delay)
+and AAC-ELD (enhanced low delay) for real-time communication.  The encoding
+library supports sample rates up to 96 kHz and up to eight channels (7.1
+surround).")
+      (license (license:fsf-free "https://github.com/mstorsjo/fdk-aac/blob/master/NOTICE"
+                                 "https://www.gnu.org/licenses/license-list.html#fdk")))))