[bug#33353] gnu: Add libcxx.

Message ID 20181112144339.13902-1-ricardo.wurmus@mdc-berlin.de
State Accepted
Headers show
Series [bug#33353] gnu: Add libcxx. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Ricardo Wurmus Nov. 12, 2018, 2:43 p.m. UTC
* gnu/packages/llvm.scm (libcxx): New variable.
---
 gnu/packages/llvm.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Ludovic Courtès Nov. 16, 2018, 10:01 p.m. UTC | #1
Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de> skribis:

> * gnu/packages/llvm.scm (libcxx): New variable.

[...]

> +    (home-page "https://libcxx.llvm.org")
> +    (synopsis "C++ standard library")
> +    (description
> +     "This package provides an implementation of the C++ standard library,
                                                                            ^
Maybe add: “for use with Clang”.

Otherwise LGTM, thanks!

Ludo’.

Patch

diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index a809180e2..848d7fde2 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -231,6 +231,29 @@  project includes the Clang front end, the Clang static analyzer, and several
 code analysis tools.")
     (license license:ncsa)))
 
+(define-public libcxx
+  (package
+    (name "libcxx")
+    (version (package-version llvm))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://llvm.org/releases/"
+                           version "/libcxx-" version ".src.tar.xz"))
+       (sha256
+        (base32
+         "0rzw4qvxp6qx4l4h9amrq02gp7hbg8lw4m0sy3k60f50234gnm3n"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("clang" ,clang)
+       ("llvm" ,llvm)))
+    (home-page "https://libcxx.llvm.org")
+    (synopsis "C++ standard library")
+    (description
+     "This package provides an implementation of the C++ standard library,
+targeting C++11, C++14 and above.")
+    (license license:expat)))
+
 (define-public clang-runtime
   (clang-runtime-from-llvm
    llvm