[bug#34967] Add emacs-python-environment

Message ID CAAc=MEy+XDLi3c3WYDTrq-oNC8yUS5qmXfdnoya_XGfjDgCPqQ@mail.gmail.com
State Accepted
Headers show
Series [bug#34967] Add emacs-python-environment | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung March 24, 2019, 12:02 a.m. UTC
See attached.

Comments

Ludovic Courtès March 25, 2019, 9:41 a.m. UTC | #1
Brian Leung <bkleung89@gmail.com> skribis:

> From d02110b2c93b6d6cc90ebd5f3a1f0c2c39719ddf Mon Sep 17 00:00:00 2001
> From: Brian Leung <bkleung89@gmail.com>
> Date: Sun, 24 Mar 2019 00:52:27 +0100
> Subject: [PATCH] gnu: Add emacs-python-environment.
>
> * gnu/packages/emacs-xyz.scm (emacs-python-environment): New variable.

Applied, thanks!

Patch

From d02110b2c93b6d6cc90ebd5f3a1f0c2c39719ddf Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sun, 24 Mar 2019 00:52:27 +0100
Subject: [PATCH] gnu: Add emacs-python-environment.

* gnu/packages/emacs-xyz.scm (emacs-python-environment): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f040b2b07..ea9e7b7a43 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3208,6 +3208,28 @@  This provides a basic API and common UI widgets such as popup tooltips
 and popup menus.")
     (license license:gpl3+)))
 
+(define-public emacs-python-environment
+  (package
+    (name "emacs-python-environment")
+    (version "0.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tkf/emacs-python-environment/")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0q6bib9nr6xiq6npzbngyfcjk87yyvwzq1zirr3z1h5wadm34lsk"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-deferred" ,emacs-deferred)))
+    (home-page "https://github.com/tkf/emacs-python-environment")
+    (synopsis "Provides a @code{virtualenv} API in Emacs Lisp")
+    (description
+     "This package permits automated installation of tools written in Python.")
+    (license license:gpl3+)))
+
 (define-public emacs-puppet-mode
   (let ((commit "b3ed5057166a4f49dfa9be638523a348b55a2fd2")
         (revision "1"))
-- 
2.21.0