diff mbox

[bug#34931,0/5] Add gPodder.

Message ID 87r2aw8ccw.fsf@gmx.com
State Accepted
Headers show

Commit Message

Pierre Langlois March 24, 2019, 4:29 p.m. UTC
Pierre Langlois writes:

> Pierre Langlois writes:
>
> (snip)
>
>>
>> * gnu/packages/podcast.scm (python-mygpoclient): New variable.
>
> Whoops, that's 'gpodder.scm' and not 'podcast.scm' too.

Attached with ChangeLog fixed.

Comments

Ludovic Courtès March 25, 2019, 9:26 a.m. UTC | #1
Hi Pierre,

Pierre Langlois <pierre.langlois@gmx.com> skribis:

> From c91de4895afd53e40081501cd2db32bb47a5b92a Mon Sep 17 00:00:00 2001
> From: Pierre Langlois <pierre.langlois@gmx.com>
> Date: Wed, 20 Mar 2019 23:55:31 +0000
> Subject: [PATCH] gnu: Add python-mygpoclient.
>
> * gnu/packages/gpodder.scm (python-mygpoclient): New variable.

This one works for me.  I changed the license to ‘gpl3+’ because source
file headers carry the “or any later version” wording, and committed.

Thanks for investigating!

Ludo’.
diff mbox

Patch

From c91de4895afd53e40081501cd2db32bb47a5b92a Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Wed, 20 Mar 2019 23:55:31 +0000
Subject: [PATCH] gnu: Add python-mygpoclient.

* gnu/packages/gpodder.scm (python-mygpoclient): New variable.
---
 gnu/packages/gpodder.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 5b872908a5..4eda95e626 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -57,6 +57,36 @@ 
 and track podcasts.")
     (license license:lgpl2.1+)))

+(define-public python-mygpoclient
+  (package
+    (name "python-mygpoclient")
+    (version "1.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mygpoclient" version))
+       (sha256
+        (base32
+         "1fi5x6k1mngr0iviw2s4n1f3y2x7pwqy5ivkcrjdprzvwr37f0mh"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-minimock" ,python-minimock)
+       ("python-nose" ,python-nose)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "make" "test"))))))
+    (home-page "https://mygpoclient.readthedocs.io")
+    (synopsis "Python library for the gPodder web service")
+    (description "@code{mygpoclient} provides an easy and structured way to
+access the @url{https://gpodder.net} web services.  In addition to
+subscription list synchronization and storage, the API supports uploading and
+downloading episode status changes.")
+    (license license:gpl3)))
+
 (define-public python-podcastparser
   (package
     (name "python-podcastparser")
--
2.21.0