[bug#34497] Add odamex

Message ID E1gwo1z-0006LE-36@rmmprod05.runbox
State Accepted
Headers show
Series [bug#34497] Add odamex | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

pkill9 Feb. 21, 2019, 1:04 p.m. UTC
Here is an updated patch.

On Wed, 20 Feb 2019 21:47:00 +0100, Ricardo Wurmus <rekado@elephly.net> wrote:

> 
> Hi pkill9,
> 
> > * gnu/packages/games.scm (odamex): New variable.
> […]
> > +       (uri (string-append
> > +             "mirror://sourceforge/odamex/Odamex/"
> > +             version
> > +             "/odamex-src-"
> > +             version
> > +             ".tar.gz"))
> 
> Please put this on fewer lines.
> 
> > +       (sha256
> > +        (base32
> > +         "1sh6lqj7vsdmnqz17hw0b6vy7xx6dp41k2sdw99ympsfa2xd1d2j"))))
> > +    (build-system cmake-build-system)
> > +    (arguments `(#:tests? #f)) ;; No tests
> 
> Please use just one semicolon.
> 
> > +    (inputs
> > +     `(("sdl" ,(@ (gnu packages sdl) sdl))
> > +       ("sdl-mixer" ,(@ (gnu packages sdl) sdl-mixer))
> > +       ("zlib" ,(@ (gnu packages compression) zlib))
> > +       ("libpng" ,(@ (gnu packages image) libpng))
> > +       ("alsa-lib" ,(@ (gnu packages linux) alsa-lib))))
> 
> This is not okay.  Please just use the plain variable names.
> 
> > +    (home-page "https://odamex.net/")
> > +    (synopsis "Multiplayer Doom port")
> > +    (description "Odamex is a free, cross-platform modification of the Doom
> > +engine that allows players to easily join servers dedicated to playing Doom
> > +online.")
> 
> Please remove “free” — all software in Guix is Free Software.
> 
> > +    (license license:gpl2)))
> 
> Looks like this is actually gpl2+ as evidenced by files like this:
> 
>     https://github.com/odamex/odamex/blob/master/server/src/d_netinfo.cpp#L12
> 
> Could you please send an updated patch?
> 
> -- 
> Ricardo

Comments

Ludovic Courtès March 23, 2019, 8:57 p.m. UTC | #1
Hello pkill9,

<pkill9@runbox.com> skribis:

> Here is an updated patch.

> From 353f9444cd71c1e93978cf9b113e3f8743f385a8 Mon Sep 17 00:00:00 2001
> From: Pkill -9 <pkill9@runbox.com>
> Date: Thu, 21 Feb 2019 13:02:07 +0000
> Subject: [PATCH] gnu: Add odamex.
>
> * gnu/packages/games.scm (odamex): New variable.

Applied, finally.  Thank you and apologies for the delay!

Ludo’.

Patch

From 353f9444cd71c1e93978cf9b113e3f8743f385a8 Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Thu, 21 Feb 2019 13:02:07 +0000
Subject: [PATCH] gnu: Add odamex.

* gnu/packages/games.scm (odamex): New variable.
---
 gnu/packages/games.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6d9e63c4e..bec38dd41 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5378,6 +5378,34 @@  Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
                     "file://dumb/licence.txt"
                     "Dumb license, explicitly GPL compatible.")))))
 
+(define-public odamex
+  (package
+    (name "odamex")
+    (version "0.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://sourceforge/odamex/Odamex/" version "/"
+             "odamex-src-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1sh6lqj7vsdmnqz17hw0b6vy7xx6dp41k2sdw99ympsfa2xd1d2j"))))
+    (build-system cmake-build-system)
+    (arguments `(#:tests? #f)) ; no tests.
+    (inputs
+     `(("sdl" ,sdl)
+       ("sdl-mixer" ,sdl-mixer)
+       ("zlib" ,zlib)
+       ("libpng" ,libpng)
+       ("alsa-lib" ,alsa-lib)))
+    (home-page "https://odamex.net/")
+    (synopsis "Multiplayer Doom port")
+    (description "Odamex is a modification of the Doom engine that
+allows players to easily join servers dedicated to playing Doom
+online.")
+    (license license:gpl2+)))
+
 (define-public fortune-mod
   (package
     (name "fortune-mod")
-- 
2.20.1